Project

General

Profile

Bug #42389

teuthology on pypi totally outdated

Added by Thomas Bechtold 7 months ago. Updated 6 months ago.

Status:
New
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
pypi
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
teuthology
Crash signature:

Description

The teuthology module on pypi (https://pypi.org/project/teuthology/) is outdated. The version there is 0.1.0 and was last updated in 2014.

I think the package
a) should be updated with every new release
b) removed from pypi so people do not install an super old version by accident

I would prefer option a)

History

#1 Updated by Nathan Cutler 7 months ago

Teuthology has not ever done any releases (at least, that I am aware of), so probably option (b) is better?

#2 Updated by Nathan Cutler 7 months ago

  • Project changed from Ceph to teuthology
  • Category deleted (teuthology)

#3 Updated by Thomas Bechtold 7 months ago

Nathan Cutler wrote:

Teuthology has not ever done any releases (at least, that I am aware of), so probably option (b) is better?

So somebody not from the Ceph community did https://pypi.org/project/teuthology/#files ?

#4 Updated by Nathan Cutler 7 months ago

  • Assignee set to Zack Cerza

So somebody not from the Ceph community did https://pypi.org/project/teuthology/#files ?

Looks like Zack did it, back in 2014 before I was involved in Ceph. Assigning the bug to him.

#5 Updated by Kyrylo Shatskyy 6 months ago

I guess it makes to get back to this topic after we finish migration to py3.

Also available in: Atom PDF