Project

General

Profile

Bug #42360

python3-cephfs should provide python36-cephfs

Added by Kefu Chai almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous, mimic, nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

when upgrading from v12 to v13:

2019-10-17T15:34:24.375 INFO:teuthology.orchestra.run.smithi099:> sudo yum -y install '' '' ceph-radosgw ceph-test ceph ceph-mgr ceph-fuse libcephfs2 libcephfs-devel librados2 li
brbd1 python-ceph rbd-fuse python3-cephfs python3-rados
...
2019-10-17T15:34:35.246 INFO:teuthology.orchestra.run.smithi099.stdout:---> Package ceph.x86_64 2:12.2.12-511.gb9c1d9f.el7 will be updated
2019-10-17T15:34:35.250 INFO:teuthology.orchestra.run.smithi099.stdout:---> Package ceph.x86_64 2:13.2.6-706.g4f9664c.el7 will be an update
...
2019-10-17T15:34:35.402 INFO:teuthology.orchestra.run.smithi099.stdout:---> Package python3-cephfs.x86_64 2:13.2.6-706.g4f9664c.el7 will be installed
2019-10-17T15:34:35.402 INFO:teuthology.orchestra.run.smithi099.stdout:--> Processing Dependency: python3-ceph-argparse = 2:13.2.6-706.g4f9664c.el7 for package: 2:python3-cephfs-13.2.6-706.g4f9664c.el7.x86_64
...
2019-10-17T15:34:36.140 INFO:teuthology.orchestra.run.smithi099.stdout:--> Finished Dependency Resolution
2019-10-17T15:34:36.193 INFO:teuthology.orchestra.run.smithi099.stderr:Error: Package: 2:python36-cephfs-12.2.12-511.gb9c1d9f.el7.x86_64 (@ceph)
2019-10-17T15:34:36.193 INFO:teuthology.orchestra.run.smithi099.stderr:           Requires: libcephfs2 = 2:12.2.12-511.gb9c1d9f.el7
2019-10-17T15:34:36.194 INFO:teuthology.orchestra.run.smithi099.stderr:           Removing: 2:libcephfs2-12.2.12-511.gb9c1d9f.el7.x86_64 (@ceph)
2019-10-17T15:34:36.194 INFO:teuthology.orchestra.run.smithi099.stderr:               libcephfs2 = 2:12.2.12-511.gb9c1d9f.el7
2019-10-17T15:34:36.194 INFO:teuthology.orchestra.run.smithi099.stderr:           Updated By: 2:libcephfs2-13.2.6-706.g4f9664c.el7.x86_64 (ceph)
2019-10-17T15:34:36.194 INFO:teuthology.orchestra.run.smithi099.stderr:               libcephfs2 = 2:13.2.6-706.g4f9664c.el7
2019-10-17T15:34:36.194 INFO:teuthology.orchestra.run.smithi099.stderr:Error: Package: 2:python36-rados-12.2.12-511.gb9c1d9f.el7.x86_64 (@ceph)
2019-10-17T15:34:36.194 INFO:teuthology.orchestra.run.smithi099.stderr:           Requires: librados2 = 2:12.2.12-511.gb9c1d9f.el7
2019-10-17T15:34:36.194 INFO:teuthology.orchestra.run.smithi099.stderr:           Removing: 2:librados2-12.2.12-511.gb9c1d9f.el7.x86_64 (@ceph)
2019-10-17T15:34:36.195 INFO:teuthology.orchestra.run.smithi099.stderr:               librados2 = 2:12.2.12-511.gb9c1d9f.el7
2019-10-17T15:34:36.195 INFO:teuthology.orchestra.run.smithi099.stderr:           Updated By: 2:librados2-13.2.6-706.g4f9664c.el7.x86_64 (ceph)
2019-10-17T15:34:36.195 INFO:teuthology.orchestra.run.smithi099.stderr:               librados2 = 2:13.2.6-706.g4f9664c.el7
2019-10-17T15:34:36.195 INFO:teuthology.orchestra.run.smithi099.stdout: You could try using --skip-broken to work around the problem
2019-10-17T15:34:44.287 INFO:teuthology.orchestra.run.smithi099.stdout: You could try running: rpm -Va --nofiles --nodigest
2019-10-17T15:34:44.369 DEBUG:teuthology.orchestra.run:got remote process result: 1

see http://pulpito.ceph.com/teuthology-2019-10-17_02:25:03-upgrade:luminous-x-mimic-distro-basic-smithi/4417295/

the crux of the problem is

i think the luminous release (12.2.12-511.gb9c1d9f.el7) was not built with the latest "python-srpm-macros" package. so it does not offer python3-* python binding packages. while the mimic release (13.2.6-706.g4f9664c.el7) was. so when we install python3-cephfs, and it required libcephfs2 (13.2.6-706.g4f9664c.el7). to install a newer libcephfs2 requires uninstall old version of this package. so "libcephfs2 = 2:12.2.12-511.gb9c1d9f.el7" would be removed. but python36-cephfs-12.2.12-511.gb9c1d9f.el7.x86_64 was still around. it was not being replaced. so i think the fix is to let python3-cephfs provide "python36-cephfs".


Related issues

Copied to RADOS - Backport #42361: luminous: python3-cephfs should provide python36-cephfs Resolved
Copied to RADOS - Backport #42362: mimic: python3-cephfs should provide python36-cephfs Resolved
Copied to RADOS - Backport #42363: nautilus: python3-cephfs should provide python36-cephfs Resolved

History

#1 Updated by Kefu Chai almost 2 years ago

  • Description updated (diff)
  • Status changed from New to In Progress
  • Pull request ID set to 30830

#2 Updated by Kefu Chai almost 2 years ago

  • Status changed from In Progress to Pending Backport

#3 Updated by Kefu Chai almost 2 years ago

  • Copied to Backport #42361: luminous: python3-cephfs should provide python36-cephfs added

#4 Updated by Kefu Chai almost 2 years ago

  • Copied to Backport #42362: mimic: python3-cephfs should provide python36-cephfs added

#5 Updated by Kefu Chai almost 2 years ago

  • Copied to Backport #42363: nautilus: python3-cephfs should provide python36-cephfs added

#6 Updated by Nathan Cutler almost 2 years ago

  • Backport set to luminous, mimic, nautilus

Output from backport-create-issue:

ERROR:root:https://tracker.ceph.com/issues/42360 the backport field is empty
ERROR:root:https://tracker.ceph.com/issues/42360 has more backport issues (luminous,mimic,nautilus) than expected ()

#7 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF