Project

General

Profile

Bug #42261

mimic and luminous still need to read ceph.conf.template from teuthology

Added by Nathan Cutler almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

In master/nautilus, https://github.com/ceph/ceph/commit/de9b77cd38970106f41376460e0842305594f5ec and https://github.com/ceph/ceph/commit/1ab352dd3105d320bd7ad2c0b37e5de750879dd5 shifted "ceph.conf.template" from the ceph/teuthology.git repo to ceph/ceph.git

However, this change did not get backported, so now we have a situation where older releases need to merge changes into ceph.conf.template at ceph/teuthology.git, while newer releases do not need to touch ceph/teuthology.git when they change ceph.conf.template.

Since a single master version of teuthology is used to test all versions of ceph, it would be desirable for all versions of ceph to access the ceph.conf.template from ceph/ceph.git like is already the case in master.


Related issues

Copied to Ceph - Backport #42263: mimic: mimic and luminous still need to read ceph.conf.template from teuthology Resolved
Copied to Ceph - Backport #42264: luminous: mimic and luminous still need to read ceph.conf.template from teuthology Resolved

History

#2 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #42263: mimic: mimic and luminous still need to read ceph.conf.template from teuthology added

#3 Updated by Nathan Cutler almost 2 years ago

  • Backport changed from mimic, nautilus to mimic, luminous

#4 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #42264: luminous: mimic and luminous still need to read ceph.conf.template from teuthology added

#5 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF