Project

General

Profile

Bug #42256

ImportError: cannot import name remote

Added by Ricardo Dias over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Core
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature:

Description

When running the dashboard QA tests locally that uses vstart_runner.sh plus a clone of the teuthology master branch it started failing with an import error as in $subject.

The full stack trace is:

Error importing packages, have you activated your teuthology virtualenv and set PYTHONPATH to point to teuthology and ceph-qa-suite?
***

Traceback (most recent call last):
  File "../qa/tasks/vstart_runner.py", line 128, in <module>
    from tasks.ceph_manager import CephManager
  File "/tmp/tmp.Q2oxTxdqZU/venv/lib/python2.7/site-packages/gevent/builtins.py", line 93, in __import__
    result = _import(*args, **kwargs)
  File "/ceph/qa/tasks/ceph_manager.py", line 22, in <module>
    from teuthology.orchestra.remote import Remote
  File "/tmp/tmp.Q2oxTxdqZU/venv/lib/python2.7/site-packages/gevent/builtins.py", line 93, in __import__
    result = _import(*args, **kwargs)
  File "/tmp/tmp.Q2oxTxdqZU/teuthology/teuthology/orchestra/remote.py", line 4, in <module>
    import teuthology.lock.query
  File "/tmp/tmp.Q2oxTxdqZU/venv/lib/python2.7/site-packages/gevent/builtins.py", line 93, in __import__
    result = _import(*args, **kwargs)
  File "/tmp/tmp.Q2oxTxdqZU/teuthology/teuthology/lock/__init__.py", line 1, in <module>
    from teuthology.lock import cli, keys, ops, query, util  # noqa
  File "/tmp/tmp.Q2oxTxdqZU/venv/lib/python2.7/site-packages/gevent/builtins.py", line 93, in __import__
    result = _import(*args, **kwargs)
  File "/tmp/tmp.Q2oxTxdqZU/teuthology/teuthology/lock/cli.py", line 15, in <module>
    from teuthology.lock import (
  File "/tmp/tmp.Q2oxTxdqZU/venv/lib/python2.7/site-packages/gevent/builtins.py", line 93, in __import__
    result = _import(*args, **kwargs)
  File "/tmp/tmp.Q2oxTxdqZU/teuthology/teuthology/lock/keys.py", line 5, in <module>
    from teuthology.lock import ops, query
  File "/tmp/tmp.Q2oxTxdqZU/venv/lib/python2.7/site-packages/gevent/builtins.py", line 93, in __import__
    result = _import(*args, **kwargs)
  File "/tmp/tmp.Q2oxTxdqZU/teuthology/teuthology/lock/ops.py", line 14, in <module>
    import teuthology.task.internal
  File "/tmp/tmp.Q2oxTxdqZU/venv/lib/python2.7/site-packages/gevent/builtins.py", line 93, in __import__
    result = _import(*args, **kwargs)
  File "/tmp/tmp.Q2oxTxdqZU/teuthology/teuthology/task/internal/__init__.py", line 21, in <module>
    from teuthology.orchestra import cluster, remote, run
ImportError: cannot import name remote

It looks like the problem is due to a loop in the import graph caused by the following change: https://github.com/ceph/teuthology/pull/1312/commits/5f5896c5ef3fa2cb3c31561dd1f25a15838658c4#diff-0c1bc86b25e221cf13dbc1b8dee22354R14


Related issues

Related to mgr - Bug #42255: mgr/dashboard: run-backend-api-test.sh is failing Closed 10/10/2019

History

#1 Updated by Ricardo Dias over 1 year ago

  • Related to Bug #42255: mgr/dashboard: run-backend-api-test.sh is failing added

#2 Updated by Ricardo Dias over 1 year ago

  • Assignee set to Ricardo Dias

#3 Updated by Ricardo Dias over 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF