Project

General

Profile

Bug #41931

mgr/rbd_support: TypeError: '>' not supported between instances of 'str' and 'int'

Added by Sebastian Wagner about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Hi, I'm getting this exception nowadays:

2019-09-19T14:15:44.614+0200 7f5e73f84700  0 mgr[rbd_support] Fatal runtime error: '>' not supported between instances of 'str' and 'int'
Traceback (most recent call last):
  File "/home/sebastian/Repos/ceph/src/pybind/mgr/rbd_support/module.py", line 165, in run
    self.query_condition.wait(stats_period)
  File "/usr/lib/python3.6/threading.py", line 298, in wait
    if timeout > 0:
TypeError: '>' not supported between instances of 'str' and 'int'

Might be a Python 3 issue.

History

#1 Updated by Jason Dillaman about 1 year ago

  • Status changed from New to Need More Info

Looks like Sage changed that w/ commit 32d4bfa732547a6d78f18786b0a379fb6f7e73d9. Are you using an up-to-date MGR?

#2 Updated by Jason Dillaman about 1 year ago

... also, are you sure this needs to be backported to Nautilus? The above commit is only in the master branch.

#3 Updated by Jason Dillaman 11 months ago

  • Status changed from Need More Info to Closed

Also available in: Atom PDF