Project

General

Profile

Bug #41926

rgw: usage show can't completed when specify --bucket

Added by Jack Lv about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
usage
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

1、To create 1000 buckets for a user
2、Specify "--bucket" option to show user's usage,such as:
radosgw-admin usage show --uid=XX --bucket=XX

you will find the process can't completed, it fall into an endless loop


Related issues

Copied to rgw - Backport #42841: nautilus: rgw: usage show can't completed when specify --bucket Resolved

History

#2 Updated by Casey Bodley about 2 years ago

  • Status changed from New to Fix Under Review

#3 Updated by Casey Bodley about 2 years ago

  • Status changed from Fix Under Review to 7

#4 Updated by Casey Bodley about 2 years ago

  • Pull request ID set to 30470

#5 Updated by Casey Bodley almost 2 years ago

  • Status changed from 7 to Pending Backport
  • Tags set to usage
  • Backport set to nautilus

#6 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #42841: nautilus: rgw: usage show can't completed when specify --bucket added

#7 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF