Project

General

Profile

Bug #41798

mgr/dashboard: Error 500 when clicking the MDS host on the Filesystems page (Raising "AttributeError: 'NoneType' object has no attribute 'get'")

Added by Lenz Grimmer about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
dashboard/cephfs
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I observed this on a vstart cluster on the current master branch (last commit: 193ef136a31b7a9ddb9d1f07f9cd72e7d0230047):

I started the cluster with this command:

RGW=1 OSD=5 MON=3 MDS=3 ../src/vstart.sh -n -x

After logging into the dashboard, I click "Filesystems" and select the row with name "a". This triggers a "500 - internal server error" toasty. Looking at the logs, I see the following backtrace:
2019-09-12T15:56:31.572+0000 7fbb906f8700  0 mgr[dashboard] [12/Sep/2019:15:56:31] HTTP 
Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/cherrypy/_cprequest.py", line 628, in respond
    self._do_respond(path_info)
  File "/usr/lib/python3.7/site-packages/cherrypy/_cprequest.py", line 687, in _do_respond
    response.body = self.handler()
  File "/usr/lib/python3.7/site-packages/cherrypy/lib/encoding.py", line 219, in __call__
    self.body = self.oldhandler(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/cherrypy/_cptools.py", line 230, in wrap
    return self.newhandler(innerfunc, *args, **kwargs)
  File "/ceph/src/pybind/mgr/dashboard/services/exception.py", line 88, in dashboard_exception_handler
    return handler(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/cherrypy/_cpdispatch.py", line 54, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/ceph/src/pybind/mgr/dashboard/controllers/__init__.py", line 645, in inner
    ret = func(*args, **kwargs)
  File "/ceph/src/pybind/mgr/dashboard/controllers/__init__.py", line 838, in wrapper
    return func(*vpath, **params)
  File "/ceph/src/pybind/mgr/dashboard/controllers/cephfs.py", line 32, in get
    return self.fs_status(fs_id)
  File "/ceph/src/pybind/mgr/dashboard/controllers/cephfs.py", line 179, in fs_status
    mds_versions[metadata.get('ceph_version', 'unknown')].append(
AttributeError: 'NoneType' object has no attribute 'get'


Related issues

Duplicates mgr - Bug #41525: mgr/dashboard: Missing service metadata is not handled correctly Resolved

History

#1 Updated by Lenz Grimmer about 1 year ago

  • Status changed from New to Duplicate

Duplicate of #41525

#2 Updated by Lenz Grimmer about 1 year ago

  • Duplicates Bug #41525: mgr/dashboard: Missing service metadata is not handled correctly added

Also available in: Atom PDF