Project

General

Profile

Bug #41776

mgr/dashboard: unable to set boolean values to false when default is true

Added by Tatjana Dehler 7 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/configurations
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The issue was originally reported on ceph-users mailinglist: http://lists.ceph.com/pipermail/ceph-users-ceph.com/2019-September/036801.html

In the config option editor it's currently not possible to set boolean values to false when the default value is true.

Tri-state_config_options_proposal.png View (28.2 KB) Ernesto Puerta, 11/13/2019 05:20 PM

iscsi_yes_no.png View (9.9 KB) Ricardo Marques, 11/14/2019 10:01 AM


Related issues

Related to mgr - Bug #42779: mgr/dashboard: cluster configuration 'boolean' and other improvements Duplicate 11/12/2019
Copied to mgr - Backport #42955: nautilus: mgr/dashboard: unable to set boolean values to false when default is true Resolved

History

#1 Updated by Ricardo Dias 7 months ago

  • Assignee set to Ricardo Dias

#2 Updated by Tatjana Dehler 7 months ago

  • Description updated (diff)

#3 Updated by Tatjana Dehler 5 months ago

  • Related to Bug #42779: mgr/dashboard: cluster configuration 'boolean' and other improvements added

#4 Updated by Ricardo Marques 5 months ago

  • Target version set to v14.2.5

#5 Updated by Ricardo Marques 5 months ago

  • Assignee changed from Ricardo Dias to Ricardo Marques

#6 Updated by Ernesto Puerta 5 months ago

@Ricardo, if you start working on this, I came up with a proposal in https://tracker.ceph.com/issues/42779. Basically, using a 'switch' (https://www.patternfly.org/v4/documentation/core/components/switch), but as Tatjana mentioned, we would need 3 states (there're tri-state patterns for both switches or check-boxes). However, I'm wondering how intuitive is that approach for users. Perhaps we should just have a left-side checkbox for overriding the default, and a switch for the True/False value, and that switch is disable if the default override is unticked? What about the following?

#7 Updated by Ricardo Marques 5 months ago

Instead of introducing a new UI component, maybe we can use something similar to what we already have in iSCSI:

(with an additional option "Default")

Alternatively, we can use a `dropdown` instead of a `radio`, but I'm more in favor of using a radio because dropdown requires an additional "click" to open the available options.

#8 Updated by Tatjana Dehler 5 months ago

Ricardo Marques wrote:

Instead of introducing a new UI component, maybe we can use something similar to what we already have in iSCSI:

Yes, I agree, we shouldn't add another UI component just because of the configs editor.

(with an additional option "Default")

Alternatively, we can use a `dropdown` instead of a `radio`, but I'm more in favor of using a radio because dropdown requires an additional "click" to open the available options.

I'm also more in favor of the radio buttons.

#9 Updated by Ernesto Puerta 5 months ago

Ok, perfect then. Also prefer to avoid the 1 extra click of the dropdown.

#10 Updated by Ricardo Marques 5 months ago

  • Status changed from New to In Progress

#11 Updated by Ricardo Marques 5 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 31738

#12 Updated by Ricardo Marques 5 months ago

  • Backport set to nautilus

#13 Updated by Lenz Grimmer 5 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Target version changed from v14.2.5 to v15.0.0

#14 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #42955: nautilus: mgr/dashboard: unable to set boolean values to false when default is true added

#15 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF