Project

General

Profile

Fix #41734

rgw: move delimiter-based bucket listing/filtering logic to cls

Added by J. Eric Ivancich about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Target version:
% Done:

0%

Source:
Tags:
Backport:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Presently, when listing the contents of a bucket using delimiters (i.e., for simulated subdirectories), the cls/osds return many more entries than will ultimately be listed. This uses CPU to encode and decode them along with network traffic to send them. This process would be much more efficient if the logic for this was pushed down to the cls/osd level.

History

#1 Updated by J. Eric Ivancich about 1 year ago

  • Status changed from Fix Under Review to Duplicate

This is a duplicate of https://tracker.ceph.com/issues/41051 .

Also available in: Atom PDF