Project

General

Profile

Bug #41655

rgw: fix minimum of unordered bucket listing

Added by Eric Ivancich about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus,mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

A recent PR (#29179) made sure that a bucket listing could not request too many entries at once. It also did a minimum computation for number of entries. For ordered listing the minimum was 0, as required to pass all unit tests. However the minimum for unordered listing was left at 1. In order to make ordered and unordered listing behave the same -- with the exception of ordering -- the minimum for unordered listing is modified to 0.


Related issues

Related to rgw - Bug #40872: rgw: when usring radosgw-admin to list bucket, can set --max-entries excessively high Resolved 07/22/2019
Copied to rgw - Backport #41806: nautilus: rgw: fix minimum of unordered bucket listing Resolved
Copied to rgw - Backport #41807: mimic: rgw: fix minimum of unordered bucket listing Resolved
Copied to rgw - Backport #41808: luminous: rgw: fix minimum of unordered bucket listing Resolved

History

#1 Updated by Eric Ivancich about 1 year ago

NOTE: Due to a dependency, backports for this tracker should not be done until the corresponding backport for https://tracker.ceph.com/issues/40872 is merged.

#2 Updated by Eric Ivancich about 1 year ago

  • Status changed from Fix Under Review to 17

#3 Updated by Nathan Cutler about 1 year ago

  • Related to Bug #40872: rgw: when usring radosgw-admin to list bucket, can set --max-entries excessively high added

#4 Updated by Abhishek Lekshmanan about 1 year ago

  • Status changed from 17 to Pending Backport

#5 Updated by Abhishek Lekshmanan about 1 year ago

  • Status changed from Pending Backport to 7

#6 Updated by Abhishek Lekshmanan about 1 year ago

  • Status changed from 7 to Pending Backport

#7 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #41806: nautilus: rgw: fix minimum of unordered bucket listing added

#8 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #41807: mimic: rgw: fix minimum of unordered bucket listing added

#9 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #41808: luminous: rgw: fix minimum of unordered bucket listing added

#10 Updated by Nathan Cutler 11 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF