Project

General

Profile

Bug #41573

mgr/dashboard: A block-manager can not access the pool page

Added by Volker Theile 21 days ago. Updated 17 days ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Category:
dashboard/pools
Target version:
Start date:
08/29/2019
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

A user with block-manager role (read-only for pools) can not access the pools page because the Angular component tries to read the 'mon_allow_pool_delete' configuration setting which will return a 403.


Related issues

Copied to mgr - Backport #41594: nautilus: mgr/dashboard: A block-manager can not access the pool page New

History

#1 Updated by Volker Theile 21 days ago

  • Status changed from New to In Progress

#2 Updated by Volker Theile 21 days ago

  • Status changed from In Progress to Need Review
  • Pull request ID set to 30001

#3 Updated by Volker Theile 17 days ago

  • Status changed from Need Review to Resolved

#4 Updated by Volker Theile 17 days ago

  • Status changed from Resolved to Pending Backport

#5 Updated by Nathan Cutler 17 days ago

  • Copied to Backport #41594: nautilus: mgr/dashboard: A block-manager can not access the pool page added

Also available in: Atom PDF