Project

General

Profile

Bug #41435

Add mgr module for kubernetes event integration

Added by anmol sachan about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
ceph-mgr
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

mgr/k8sevents: Add new mgr module for kubernetes event integration

New mgr module to provide a means of sending ceph related events to the kubernetes
events API, and also retrieval of all kubernetes events from the rook-ceph namespace.
Events may be viewed by a ceph k8sevents namespace command which will show
similar output at the ceph cli to a native kubernetes client kubectl get events command.

Since the events are cached by the module, it would also be possible to expose them to
other mgr module(s) e.g. dashboard


Related issues

Related to mgr - Bug #41737: mgr/k8sevents: exception in non-kubernetes environment Resolved 09/10/2019
Copied to mgr - Backport #41720: nautilus: Add mgr module for kubernetes event integration Resolved

History

#1 Updated by Sebastian Wagner 11 months ago

  • Status changed from New to Pending Backport
  • Backport changed from v14.2.3 to nautilus

#2 Updated by Sebastian Wagner 11 months ago

  • Copied to Backport #41720: nautilus: Add mgr module for kubernetes event integration added

#3 Updated by Nathan Cutler 11 months ago

  • Related to Bug #41737: mgr/k8sevents: exception in non-kubernetes environment added

#4 Updated by Nathan Cutler 11 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF