Project

General

Profile

Bug #41424

readable.sh test fails

Added by Kefu Chai 11 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

Description

```
104: **** failed to decode /var/ssd/ceph/ceph-object-corpus/archive/15.0.0-539-g191ab33faf/objects/ServiceMap::Service/08800c908429da57f2b09b5cc8463080 ****
104: error: buffer::malformed_input: void entity_addr_t::decode(ceph::buffer::v14_2_0::list::const_iterator&) no longer understand old encoding version 1 < 28
104: error: buffer::malformed_input: void entity_addr_t::decode(ceph::buffer::v14_2_0::list::const_iterator&) no longer understand old encoding version 1 < 28
104: **** failed to decode /var/ssd/ceph/ceph-object-corpus/archive/15.0.0-539-g191ab33faf/objects/ServiceMap/074825661e8e8a3fbcb1705c109ad5db ****
104: error: buffer::malformed_input: void entity_addr_t::decode(ceph::buffer::v14_2_0::list::const_iterator&) no longer understand old encoding version 1 < 28
104: error: buffer::malformed_input: void entity_addr_t::decode(ceph::buffer::v14_2_0::list::const_iterator&) no longer understand old encoding version 1 < 28
104: error: buffer::malformed_input: void entity_addr_t::decode(ceph::buffer::v14_2_0::list::const_iterator&) no longer understand old encoding version 1 < 28

caused by https://github.com/ceph/ceph/pull/28855 , where ServiceMap::Daemon::gid is changed from uint64_t to boost::optional<uint64_t>.


Related issues

Copied to RADOS - Backport #42168: nautilus: readable.sh test fails Resolved

History

#1 Updated by Kefu Chai 11 months ago

  • Category set to Correctness/Safety
  • Assignee set to Venky Shankar

#2 Updated by Kefu Chai 11 months ago

  • Assignee changed from Venky Shankar to Kefu Chai

#3 Updated by Kefu Chai 11 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 32281

#4 Updated by Kefu Chai 11 months ago

  • Pull request ID changed from 32281 to 29862

#5 Updated by Kefu Chai 11 months ago

  • Status changed from Fix Under Review to Resolved

#6 Updated by Venky Shankar 9 months ago

#7 Updated by Venky Shankar 9 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to nautilus

#9 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF