Project

General

Profile

Bug #41409

[test] rbd-nbd FSX test runs are failing

Added by Jason Dillaman almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Jason Dillaman
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous,mimic,nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):


Related issues

Copied to rbd - Backport #41543: mimic: [test] rbd-nbd FSX test runs are failing Resolved
Copied to rbd - Backport #41544: luminous: [test] rbd-nbd FSX test runs are failing Resolved
Copied to rbd - Backport #41545: nautilus: [test] rbd-nbd FSX test runs are failing Resolved

History

#1 Updated by Jason Dillaman almost 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman almost 2 years ago

  • Backport set to luminous,mimic,nautilus

#3 Updated by Jason Dillaman almost 2 years ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 29858

#4 Updated by Jason Dillaman almost 2 years ago

The failures appear to be related to an NBD driver change to always enable IO timeouts by default. With the OSD thrasher running, this randomly results in the NBD socket being closed by the kernel due to IO timeouts. The second commit of the PR addresses a seg fault that was recently introduced on the master branch only.

#5 Updated by Mykola Golub almost 2 years ago

  • Status changed from Fix Under Review to Pending Backport

#6 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #41543: mimic: [test] rbd-nbd FSX test runs are failing added

#7 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #41544: luminous: [test] rbd-nbd FSX test runs are failing added

#8 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #41545: nautilus: [test] rbd-nbd FSX test runs are failing added

#9 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF