Project

General

Profile

Bug #41387

"Register with subscription-manager."fails after 5 retries

Added by Kefu Chai 28 days ago. Updated 28 days ago.

Status:
Resolved
Priority:
High
Category:
Test Node
Target version:
-
Start date:
08/22/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

TASK [common : Determine if node is registered with subscription-manager.] *****
...
2019-08-22T07:52:14.364 INFO:teuthology.task.ansible.out:FAILED - RETRYING: Register with subscription-manager. (5 retries left).

2019-08-22T07:52:24.949 INFO:teuthology.task.ansible.out:FAILED - RETRYING: Register with subscription-manager. (4 retries left).

2019-08-22T07:52:36.364 INFO:teuthology.task.ansible.out:FAILED - RETRYING: Register with subscription-manager. (3 retries left).

2019-08-22T07:52:46.903 INFO:teuthology.task.ansible.out:FAILED - RETRYING: Register with subscription-manager. (2 retries left).

2019-08-22T07:52:58.393 INFO:teuthology.task.ansible.out:FAILED - RETRYING: Register with subscription-manager. (1 retries left).
...
2019-08-22T07:53:08.952 INFO:teuthology.task.ansible.out:
TASK [common : Register with subscription-manager.] ****************************

2019-08-22T07:53:08.953 INFO:teuthology.task.ansible.out:fatal: [smithi176.front.sepia.ceph.com]: FAILED! => {"attempts": 5, "censored": "the output has been hidden due to the fact that 'no_log: true' was specified for this result", "changed": true}
...
AnsibleFailedError: {'smithi176.front.sepia.ceph.com': {'attempts': 5, 'changed': True, 'censored': "the output has been hidden due to the fact that 'no_log: true' was specified for this result"}}

see also https://github.com/ceph/ceph-cm-ansible/blob/44058b25a83a05aa5fcd37b54ae79c239e2b9f6d/roles/common/tasks/rhel-entitlements.yml#L39

see also http://pulpito.ceph.com/kchai-2019-08-22_07:38:30-perf-basic-master-distro-basic-smithi/4240898/

http://pulpito.ceph.com/kchai-2019-08-22_07:26:20-perf-basic-master-distro-basic-smithi/4240895/

History

#1 Updated by David Galloway 28 days ago

  • Status changed from New to Resolved

I attempted to force the Satellite server to refresh its repos last night and it ended up stalling and leaving the whole service in a bad state.

I rebooted the VM and resynced the repos successfully. RHEL nodes can subscribe again and we have RHEL7.7 available on top of it.

#2 Updated by Kefu Chai 28 days ago

Thank you David!

Also available in: Atom PDF