Project

General

Profile

Bug #41375

rgw: A new user is created automatically when creating a bucket

Added by Volker Theile 26 days ago. Updated 25 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
08/21/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

When i create a new bucket using the Dashboard a new user <OWNER>.buckets is created.

To reproduce this in vstart simply go to the 'Object Gateway | Buckets' menu and press 'Create'. Enter the following:

Name: test
Owner: dev
Placement target: Leave default selection

Press 'Create Bucket'. The bucket is created and a new user called 'dev.buckets'. IMO this is a bug because the user can not be queried.

# radosgw-admin bucket list                                                                                         
[
    "test" 
]

# radosgw-admin metadata list user
[
    "56789abcdef0123456789abcdef0123456789abcdef0123456789abcdef01234",
    "testx$9876543210abcdef0123456789abcdef0123456789abcdef0123456789abcdef",
    "0123456789abcdef0123456789abcdef0123456789abcdef0123456789abcdef",
    "dev.buckets",
    "test",
    "testid",
    "dev" 
]

# radosgw-admin user info --uid="dev.buckets" 
2019-08-21T15:21:49.372+0000 7f94a9ad78c0  0 ERROR: failed to decode user info, caught buffer::error
could not fetch user info: no user info saved

History

#1 Updated by Matt Benjamin 25 days ago

sounds like dashboard only?

#2 Updated by Matt Benjamin 25 days ago

  • Status changed from New to Triaged

#3 Updated by Matt Benjamin 25 days ago

  • Status changed from Triaged to Resolved

Also available in: Atom PDF