Project

General

Profile

Bug #41306

Feature #39478: mgr/dashboard: new RGW workflows & RGW enhancements

Feature #39477: mgr/dashboard: add/edit missing RGW bucket info

Fix #41180: mgr/dashboard: fix bucket operations with tenant after new bucket utilities implementation

mgr/dashboard: Teuthology test failure "test_create_get_update_delete_w_tenant (tasks.mgr.dashboard.test_rgw.RgwBucketTest)"

Added by Tatjana Dehler 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
dashboard/qa
Target version:
-
% Done:

100%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

http://pulpito.ceph.com/tdehler-2019-08-15_07:04:09-rados:mgr-wip-tdehler-testing-29614-distro-basic-mira/

2019-08-16T06:13:31.127 INFO:tasks.cephfs_test_runner:======================================================================
2019-08-16T06:13:31.127 INFO:tasks.cephfs_test_runner:FAIL: test_create_get_update_delete_w_tenant (tasks.mgr.dashboard.test_rgw.RgwBucketTest)
2019-08-16T06:13:31.127 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-08-16T06:13:31.127 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-08-16T06:13:31.128 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-tdehler-testing-29614/qa/tasks/mgr/dashboard/test_rgw.py", line 250, in test_create_get_update_delete_w_tenant
2019-08-16T06:13:31.128 INFO:tasks.cephfs_test_runner:    self.assertIn('owner', data)
2019-08-16T06:13:31.128 INFO:tasks.cephfs_test_runner:AssertionError: 'owner' not found in u''
2019-08-16T06:13:31.128 INFO:tasks.cephfs_test_runner:
2019-08-16T06:13:31.128 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-08-16T06:13:31.129 INFO:tasks.cephfs_test_runner:Ran 71 tests in 997.305s
2019-08-16T06:13:31.129 INFO:tasks.cephfs_test_runner:
2019-08-16T06:13:31.129 INFO:tasks.cephfs_test_runner:FAILED (failures=1)
2019-08-16T06:13:31.129 INFO:tasks.cephfs_test_runner:
2019-08-16T06:13:31.130 INFO:tasks.cephfs_test_runner:======================================================================
2019-08-16T06:13:31.130 INFO:tasks.cephfs_test_runner:FAIL: test_create_get_update_delete_w_tenant (tasks.mgr.dashboard.test_rgw.RgwBucketTest)
2019-08-16T06:13:31.130 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-08-16T06:13:31.130 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-08-16T06:13:31.130 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-tdehler-testing-29614/qa/tasks/mgr/dashboard/test_rgw.py", line 250, in test_create_get_update_delete_w_tenant
2019-08-16T06:13:31.130 INFO:tasks.cephfs_test_runner:    self.assertIn('owner', data)
2019-08-16T06:13:31.131 INFO:tasks.cephfs_test_runner:AssertionError: 'owner' not found in u''
2019-08-16T06:13:31.131 INFO:tasks.cephfs_test_runner:

Related issues

Related to rgw - Bug #41355: RGWOp_Bucket_Info responds with an empty body instead of reporting errors New

History

#1 Updated by Tatjana Dehler 12 months ago

  • Description updated (diff)

#2 Updated by Kefu Chai 12 months ago

  • Status changed from New to 12

/kchai-2019-08-16_11:16:42-rados-wip-kefu-testing-2019-08-16-1501-distro-basic-smithi/4221379/

#3 Updated by Alfonso Martínez 12 months ago

  • Parent task set to #41180

#4 Updated by Casey Bodley 12 months ago

  • Assignee set to Marcus Watts

thanks to Alfonso for capturing some radosgw debug logs. they show that the bucket_link request isn't renaming the bucket from 'testx/teuth-test-bucket' to 'teuth-test-bucket', so the following get_bucket_info request is failing to find 'teuth-test-bucket'; there appears to be a bug in get_bucket_info, where it responds with an empty body instead of reporting the error as 404 Not Found (see https://tracker.ceph.com/issues/41355)

i believe the behavior of bucket_link is intended (assigning Marcus to corroborate); if you want to link the bucket under a new name (ie. make it visible under a different tenant), you have to provide an extra parameter paramter ?new-bucket-name=teuth-test-bucket

2019-08-20T14:31:19.171+0000 7f92b7520700 20 CONTENT_LENGTH=0
2019-08-20T14:31:19.171+0000 7f92b7520700 20 HTTP_ACCEPT=application/json
2019-08-20T14:31:19.171+0000 7f92b7520700 20 HTTP_ACCEPT_ENCODING=gzip, deflate
2019-08-20T14:31:19.171+0000 7f92b7520700 20 HTTP_AUTHORIZATION=AWS admin:6svFMIlDBRXzTXjEVqQfsBZ/q5M=
2019-08-20T14:31:19.171+0000 7f92b7520700 20 HTTP_CONNECTION=keep-alive
2019-08-20T14:31:19.171+0000 7f92b7520700 20 HTTP_DATE=Tue, 20 Aug 2019 14:31:19 GMT
2019-08-20T14:31:19.171+0000 7f92b7520700 20 HTTP_HOST=172.20.0.2:8000
2019-08-20T14:31:19.171+0000 7f92b7520700 20 HTTP_USER_AGENT=python-requests/2.6.0 CPython/2.7.5 Linux/5.2.8-200.fc30.x86_64
2019-08-20T14:31:19.171+0000 7f92b7520700 20 HTTP_VERSION=1.1
2019-08-20T14:31:19.171+0000 7f92b7520700 20 QUERY_STRING=bucket=testx%2Fteuth-test-bucket&bucket-id=4fa96187-a9ff-44cb-8ec2-593ffed20a32.4192.2&uid=admin
2019-08-20T14:31:19.171+0000 7f92b7520700 20 REMOTE_ADDR=172.20.0.2
2019-08-20T14:31:19.171+0000 7f92b7520700 20 REQUEST_METHOD=PUT
2019-08-20T14:31:19.171+0000 7f92b7520700 20 REQUEST_URI=/admin/bucket
2019-08-20T14:31:19.171+0000 7f92b7520700 20 SCRIPT_URI=/admin/bucket
2019-08-20T14:31:19.171+0000 7f92b7520700 20 SERVER_PORT=8000
2019-08-20T14:31:19.171+0000 7f92b7520700  1 ====== starting new request req=0x55fa5f6e08e0 =====
2019-08-20T14:31:19.171+0000 7f92b7520700  2 req 13 0s initializing for trans_id = tx00000000000000000000d-005d5c0437-105e-default
2019-08-20T14:31:19.172+0000 7f92b7520700 10 rgw api priority: s3=7 s3website=6
2019-08-20T14:31:19.172+0000 7f92b7520700 10 host=172.20.0.2
2019-08-20T14:31:19.172+0000 7f92b7520700 20 subdomain= domain= in_hosted_domain=0 in_hosted_domain_s3website=0
2019-08-20T14:31:19.172+0000 7f92b7520700 20 final domain/bucket subdomain= domain= in_hosted_domain=0 in_hosted_domain_s3website=0 s->info.domain= s->info.request_uri=/admin/bucket
2019-08-20T14:31:19.172+0000 7f92b7520700 10 handler=17RGWHandler_Bucket
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s getting op 1
2019-08-20T14:31:19.172+0000 7f92b7520700 10 req 13 0.000999988s :link_bucket scheduling with dmclock client=0 cost=1
2019-08-20T14:31:19.172+0000 7f92b7520700 10 op=17RGWOp_Bucket_Link
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket verifying requester
2019-08-20T14:31:19.172+0000 7f92b7520700 20 req 13 0.000999988s :link_bucket rgw::auth::StrategyRegistry::s3_main_strategy_t: trying rgw::auth::s3::AWSAuthStrategy
2019-08-20T14:31:19.172+0000 7f92b7520700 20 req 13 0.000999988s :link_bucket rgw::auth::s3::AWSAuthStrategy: trying rgw::auth::s3::S3AnonymousEngine
2019-08-20T14:31:19.172+0000 7f92b7520700 20 req 13 0.000999988s :link_bucket rgw::auth::s3::S3AnonymousEngine denied with reason=-1
2019-08-20T14:31:19.172+0000 7f92b7520700 20 req 13 0.000999988s :link_bucket rgw::auth::s3::AWSAuthStrategy: trying rgw::auth::s3::LocalEngine
2019-08-20T14:31:19.172+0000 7f92b7520700 10 get_canon_resource(): dest=/admin/bucket
2019-08-20T14:31:19.172+0000 7f92b7520700 10 req 13 0.000999988s string_to_sign:
PUT

Tue, 20 Aug 2019 14:31:19 GMT
/admin/bucket
2019-08-20T14:31:19.172+0000 7f92b7520700 15 req 13 0.000999988s :link_bucket string_to_sign=PUT

Tue, 20 Aug 2019 14:31:19 GMT
/admin/bucket
2019-08-20T14:31:19.172+0000 7f92b7520700 15 req 13 0.000999988s :link_bucket server signature=6svFMIlDBRXzTXjEVqQfsBZ/q5M=
2019-08-20T14:31:19.172+0000 7f92b7520700 15 req 13 0.000999988s :link_bucket client signature=6svFMIlDBRXzTXjEVqQfsBZ/q5M=
2019-08-20T14:31:19.172+0000 7f92b7520700 15 req 13 0.000999988s :link_bucket compare=0
2019-08-20T14:31:19.172+0000 7f92b7520700 20 req 13 0.000999988s :link_bucket rgw::auth::s3::LocalEngine granted access
2019-08-20T14:31:19.172+0000 7f92b7520700 20 req 13 0.000999988s :link_bucket rgw::auth::s3::AWSAuthStrategy granted access
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket normalizing buckets and tenants
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket init permissions
2019-08-20T14:31:19.172+0000 7f92b7520700 20 get_system_obj_state: rctx=0x55fa5f6def98 obj=default.rgw.meta:users.uid:admin state=0x55fa5f7316c0 s->prefetch_data=0
2019-08-20T14:31:19.172+0000 7f92b7520700 10 cache get: name=default.rgw.meta+users.uid+admin : hit (requested=0x6, cached=0x17)
2019-08-20T14:31:19.172+0000 7f92b7520700 20 get_system_obj_state: s->obj_tag was set empty
2019-08-20T14:31:19.172+0000 7f92b7520700 20 Read xattr: user.rgw.idtag
2019-08-20T14:31:19.172+0000 7f92b7520700 10 cache get: name=default.rgw.meta+users.uid+admin : hit (requested=0x3, cached=0x17)
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket recalculating target
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket reading permissions
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket init op
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket verifying op mask
2019-08-20T14:31:19.172+0000 7f92b7520700 20 req 13 0.000999988s :link_bucket required_mask= 0 user.op_mask=7
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket verifying op permissions
2019-08-20T14:31:19.172+0000 7f92b7520700  2 overriding permissions due to system operation
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket verifying op params
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket pre-executing
2019-08-20T14:31:19.172+0000 7f92b7520700  2 req 13 0.000999988s :link_bucket executing
2019-08-20T14:31:19.172+0000 7f92b7520700 20 get_system_obj_state: rctx=0x55fa5f6deee8 obj=default.rgw.meta:root:testx/teuth-test-bucket state=0x55fa5f7316c0 s->prefetch_data=0
2019-08-20T14:31:19.172+0000 7f92b7520700 10 cache get: name=default.rgw.meta+root+testx/teuth-test-bucket : hit (requested=0x16, cached=0x17)
2019-08-20T14:31:19.172+0000 7f92b7520700 20 get_system_obj_state: s->obj_tag was set empty
2019-08-20T14:31:19.172+0000 7f92b7520700 10 cache get: name=default.rgw.meta+root+testx/teuth-test-bucket : hit (requested=0x11, cached=0x17)
2019-08-20T14:31:19.172+0000 7f92b7520700 20 get_system_obj_state: rctx=0x55fa5f6df1c8 obj=default.rgw.meta:users.uid:admin state=0x55fa5f7316c0 s->prefetch_data=0
2019-08-20T14:31:19.172+0000 7f92b7520700 10 cache get: name=default.rgw.meta+users.uid+admin : hit (requested=0x6, cached=0x17)
2019-08-20T14:31:19.172+0000 7f92b7520700 20 get_system_obj_state: s->obj_tag was set empty
2019-08-20T14:31:19.172+0000 7f92b7520700 10 cache get: name=default.rgw.meta+users.uid+admin : hit (requested=0x1, cached=0x17)
2019-08-20T14:31:19.172+0000 7f92b7520700 20 WARNING: blocking librados call
2019-08-20T14:31:19.172+0000 7f92b7520700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6802/1586,v1:172.20.0.2:6803/1586] -- osd_op(unknown.0.0:325 3.6 3:764897a2:users.uid::testx$teuth-test-user.buckets:head [call user.remove_bucket] snapc 0=[] ondisk+write+known_if_redirected e32) v8 -- 0x55fa5f5acdc0 con 0x55fa5e611c00
2019-08-20T14:31:19.178+0000 7f92e7d81700  1 -- 172.20.0.2:0/1405484245 <== osd.0 v2:172.20.0.2:6802/1586 48 ==== osd_op_reply(325 testx$teuth-test-user.buckets [call] v32'6 uv6 ondisk = 0) v8 ==== 173+0+0 (crc 0 0 0) 0x55fa5f5d6500 con 0x55fa5e611c00
2019-08-20T14:31:19.178+0000 7f92b7520700 20 WARNING: blocking librados call
2019-08-20T14:31:19.178+0000 7f92b7520700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6818/2246,v1:172.20.0.2:6819/2246] -- osd_op(unknown.0.0:326 3.5 3:b80e83ea:root::.bucket.meta.testx%3ateuth-test-bucket%3a4fa96187-a9ff-44cb-8ec2-593ffed20a32.4192.2:head [delete,create,call version.check_conds,call version.set,writefull 0~285,setxattr user.rgw.acl (135)] snapc 0=[] ondisk+write+known_if_redirected e32) v8 -- 0x55fa5f5b22c0 con 0x55fa5f31dc00
2019-08-20T14:31:19.185+0000 7f92e7d81700  1 -- 172.20.0.2:0/1405484245 <== osd.2 v2:172.20.0.2:6818/2246 42 ==== osd_op_reply(326 .bucket.meta.testx:teuth-test-bucket:4fa96187-a9ff-44cb-8ec2-593ffed20a32.4192.2 [delete,create,call,call,writefull 0~285,setxattr (135)] v32'5 uv5 ondisk = 0) v8 ==== 434+0+0 (crc 0 0 0) 0x55fa5f5d6500 con 0x55fa5f31dc00
2019-08-20T14:31:19.185+0000 7f92b7520700 10 cache put: name=default.rgw.meta+root+.bucket.meta.testx:teuth-test-bucket:4fa96187-a9ff-44cb-8ec2-593ffed20a32.4192.2 info.flags=0x17
2019-08-20T14:31:19.185+0000 7f92b7520700 10 moving default.rgw.meta+root+.bucket.meta.testx:teuth-test-bucket:4fa96187-a9ff-44cb-8ec2-593ffed20a32.4192.2 to cache LRU end
2019-08-20T14:31:19.185+0000 7f92b7520700 10 updating xattr: name=user.rgw.acl bl.length()=135
2019-08-20T14:31:19.185+0000 7f92b7520700 10 distributing notification oid=default.rgw.control:notify.5 bl.length()=688
2019-08-20T14:31:19.185+0000 7f92b7520700 20 WARNING: blocking librados call
2019-08-20T14:31:19.185+0000 7f92b7520700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6826/2576,v1:172.20.0.2:6827/2576] -- osd_op(unknown.0.0:327 2.3 2:c609908c:::notify.5:head [notify cookie 94533831652992] snapc 0=[] ondisk+read+known_if_redirected e32) v8 -- 0x55fa5e5bedc0 con 0x55fa5f31d800
2019-08-20T14:31:19.186+0000 7f92e6d7f700  1 -- 172.20.0.2:0/1405484245 <== osd.3 v2:172.20.0.2:6826/2576 145 ==== watch-notify(notify (1) cookie 94533827433472 notify 137438953488 ret 0) v3 ==== 730+0+0 (crc 0 0 0) 0x55fa5f726240 con 0x55fa5f31d800
2019-08-20T14:31:19.186+0000 7f92e2d77700 10 RGWWatcher::handle_notify()  notify_id 137438953488 cookie 94533827433472 notifier 4190 bl.length()=688
2019-08-20T14:31:19.186+0000 7f92e6d7f700  1 -- 172.20.0.2:0/1405484245 <== osd.3 v2:172.20.0.2:6826/2576 146 ==== osd_op_reply(327 notify.5 [notify cookie 94533831652992] v0'0 uv33 ondisk = 0) v8 ==== 152+0+8 (crc 0 0 0) 0x55fa5f746000 con 0x55fa5f31d800
2019-08-20T14:31:19.186+0000 7f92e2d77700 10 cache put: name=default.rgw.meta+root+.bucket.meta.testx:teuth-test-bucket:4fa96187-a9ff-44cb-8ec2-593ffed20a32.4192.2 info.flags=0x17
2019-08-20T14:31:19.186+0000 7f92e2d77700 10 moving default.rgw.meta+root+.bucket.meta.testx:teuth-test-bucket:4fa96187-a9ff-44cb-8ec2-593ffed20a32.4192.2 to cache LRU end
2019-08-20T14:31:19.186+0000 7f92e2d77700 10 updating xattr: name=user.rgw.acl bl.length()=135
2019-08-20T14:31:19.186+0000 7f92e2d77700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6826/2576,v1:172.20.0.2:6827/2576] -- osd_op(unknown.0.0:328 2.3 2:c609908c:::notify.5:head [notify-ack] snapc 0=[] ondisk+read+known_if_redirected e32) v8 -- 0x55fa5f5ac2c0 con 0x55fa5f31d800
2019-08-20T14:31:19.186+0000 7f92e6d7f700  1 -- 172.20.0.2:0/1405484245 <== osd.3 v2:172.20.0.2:6826/2576 147 ==== watch-notify(notify_complete (2) cookie 94533831652992 notify 137438953488 ret 0) v3 ==== 42+0+28 (crc 0 0 0) 0x55fa5f726480 con 0x55fa5f31d800
2019-08-20T14:31:19.186+0000 7f92e6d7f700  1 -- 172.20.0.2:0/1405484245 <== osd.3 v2:172.20.0.2:6826/2576 148 ==== osd_op_reply(328 notify.5 [notify-ack] v0'0 uv33 ondisk = 0) v8 ==== 152+0+0 (crc 0 0 0) 0x55fa5f746000 con 0x55fa5f31d800
2019-08-20T14:31:19.186+0000 7f92b7520700 20 WARNING: blocking librados call
2019-08-20T14:31:19.186+0000 7f92b7520700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6810/1916,v1:172.20.0.2:6811/1916] -- osd_op(unknown.0.0:329 3.0 3:04c91fa6:users.uid::admin.buckets:head [call user.set_buckets_info] snapc 0=[] ondisk+write+known_if_redirected e32) v8 -- 0x55fa5f504580 con 0x55fa5f31c000
2019-08-20T14:31:19.190+0000 7f92e7580700  1 -- 172.20.0.2:0/1405484245 <== osd.1 v2:172.20.0.2:6810/1916 112 ==== osd_op_reply(329 admin.buckets [call] v32'7 uv7 ondisk = 0) v8 ==== 157+0+0 (crc 0 0 0) 0x55fa5f6e2000 con 0x55fa5f31c000
2019-08-20T14:31:19.190+0000 7f92b7520700 20 WARNING: blocking librados call
2019-08-20T14:31:19.190+0000 7f92b7520700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6826/2576,v1:172.20.0.2:6827/2576] -- osd_op(unknown.0.0:330 3.7 3:ed14984a:root::testx%2fteuth-test-bucket:head [delete,create,call version.inc,writefull 0~182] snapc 0=[] ondisk+write+known_if_redirected e32) v8 -- 0x55fa5f5b2000 con 0x55fa5f31d800
2019-08-20T14:31:19.197+0000 7f92e6d7f700  1 -- 172.20.0.2:0/1405484245 <== osd.3 v2:172.20.0.2:6826/2576 149 ==== osd_op_reply(330 testx/teuth-test-bucket [delete,create,call,writefull 0~182] v32'4 uv4 ondisk = 0) v8 ==== 293+0+0 (crc 0 0 0) 0x55fa5f746000 con 0x55fa5f31d800
2019-08-20T14:31:19.197+0000 7f92b7520700 10 cache put: name=default.rgw.meta+root+testx/teuth-test-bucket info.flags=0x17
2019-08-20T14:31:19.197+0000 7f92b7520700 10 moving default.rgw.meta+root+testx/teuth-test-bucket to cache LRU end
2019-08-20T14:31:19.197+0000 7f92b7520700 10 distributing notification oid=default.rgw.control:notify.7 bl.length()=349
2019-08-20T14:31:19.197+0000 7f92b7520700 20 WARNING: blocking librados call
2019-08-20T14:31:19.199+0000 7f92b7520700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6818/2246,v1:172.20.0.2:6819/2246] -- osd_op(unknown.0.0:331 2.1 2:93e5b521:::notify.7:head [notify cookie 94533831692032] snapc 0=[] ondisk+read+known_if_redirected e32) v8 -- 0x55fa5f5b2580 con 0x55fa5f31dc00
2019-08-20T14:31:19.199+0000 7f92e7d81700  1 -- 172.20.0.2:0/1405484245 <== osd.2 v2:172.20.0.2:6818/2246 43 ==== watch-notify(notify (1) cookie 94533827429632 notify 137438953476 ret 0) v3 ==== 391+0+0 (crc 0 0 0) 0x55fa5f7a06c0 con 0x55fa5f31dc00
2019-08-20T14:31:19.199+0000 7f92e7d81700  1 -- 172.20.0.2:0/1405484245 <== osd.2 v2:172.20.0.2:6818/2246 44 ==== osd_op_reply(331 notify.7 [notify cookie 94533831692032] v0'0 uv33 ondisk = 0) v8 ==== 152+0+8 (crc 0 0 0) 0x55fa5f5d3680 con 0x55fa5f31dc00
2019-08-20T14:31:19.199+0000 7f92e2d77700 10 RGWWatcher::handle_notify()  notify_id 137438953476 cookie 94533827429632 notifier 4190 bl.length()=349
2019-08-20T14:31:19.199+0000 7f92e2d77700 10 cache put: name=default.rgw.meta+root+testx/teuth-test-bucket info.flags=0x17
2019-08-20T14:31:19.199+0000 7f92e2d77700 10 moving default.rgw.meta+root+testx/teuth-test-bucket to cache LRU end
2019-08-20T14:31:19.199+0000 7f92e2d77700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6818/2246,v1:172.20.0.2:6819/2246] -- osd_op(unknown.0.0:332 2.1 2:93e5b521:::notify.7:head [notify-ack] snapc 0=[] ondisk+read+known_if_redirected e32) v8 -- 0x55fa5f6ce000 con 0x55fa5f31dc00
2019-08-20T14:31:19.200+0000 7f92e7d81700  1 -- 172.20.0.2:0/1405484245 <== osd.2 v2:172.20.0.2:6818/2246 45 ==== watch-notify(notify_complete (2) cookie 94533831692032 notify 137438953476 ret 0) v3 ==== 42+0+28 (crc 0 0 0) 0x55fa5f7a0900 con 0x55fa5f31dc00
2019-08-20T14:31:19.200+0000 7f92e7d81700  1 -- 172.20.0.2:0/1405484245 <== osd.2 v2:172.20.0.2:6818/2246 46 ==== osd_op_reply(332 notify.7 [notify-ack] v0'0 uv33 ondisk = 0) v8 ==== 152+0+0 (crc 0 0 0) 0x55fa5f5d3680 con 0x55fa5f31dc00
2019-08-20T14:31:19.200+0000 7f92b7520700  2 req 13 0.028999641s :link_bucket completing
2019-08-20T14:31:19.200+0000 7f92b7520700  2 req 13 0.028999641s :link_bucket op status=0
2019-08-20T14:31:19.200+0000 7f92b7520700  2 req 13 0.028999641s :link_bucket http status=200
2019-08-20T14:31:19.200+0000 7f92b7520700  1 ====== req done req=0x55fa5f6e08e0 op status=0 http_status=200 latency=0.028999641s ======
2019-08-20T14:31:19.211+0000 7f92b3518700 20 HTTP_ACCEPT=application/json
2019-08-20T14:31:19.211+0000 7f92b3518700 20 HTTP_ACCEPT_ENCODING=gzip, deflate
2019-08-20T14:31:19.211+0000 7f92b3518700 20 HTTP_AUTHORIZATION=AWS admin:bfww17S8wccruc0Uz75x5y6mE1E=
2019-08-20T14:31:19.211+0000 7f92b3518700 20 HTTP_CONNECTION=keep-alive
2019-08-20T14:31:19.211+0000 7f92b3518700 20 HTTP_DATE=Tue, 20 Aug 2019 14:31:19 GMT
2019-08-20T14:31:19.211+0000 7f92b3518700 20 HTTP_HOST=172.20.0.2:8000
2019-08-20T14:31:19.211+0000 7f92b3518700 20 HTTP_USER_AGENT=python-requests/2.6.0 CPython/2.7.5 Linux/5.2.8-200.fc30.x86_64
2019-08-20T14:31:19.211+0000 7f92b3518700 20 HTTP_VERSION=1.1
2019-08-20T14:31:19.211+0000 7f92b3518700 20 QUERY_STRING=bucket=teuth-test-bucket
2019-08-20T14:31:19.211+0000 7f92b3518700 20 REMOTE_ADDR=172.20.0.2
2019-08-20T14:31:19.211+0000 7f92b3518700 20 REQUEST_METHOD=GET
2019-08-20T14:31:19.211+0000 7f92b3518700 20 REQUEST_URI=/admin/bucket
2019-08-20T14:31:19.211+0000 7f92b3518700 20 SCRIPT_URI=/admin/bucket
2019-08-20T14:31:19.211+0000 7f92b3518700 20 SERVER_PORT=8000
2019-08-20T14:31:19.211+0000 7f92b3518700  1 ====== starting new request req=0x55fa5f6e08e0 =====
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s initializing for trans_id = tx00000000000000000000e-005d5c0437-105e-default
2019-08-20T14:31:19.211+0000 7f92b3518700 10 rgw api priority: s3=7 s3website=6
2019-08-20T14:31:19.211+0000 7f92b3518700 10 host=172.20.0.2
2019-08-20T14:31:19.211+0000 7f92b3518700 20 subdomain= domain= in_hosted_domain=0 in_hosted_domain_s3website=0
2019-08-20T14:31:19.211+0000 7f92b3518700 20 final domain/bucket subdomain= domain= in_hosted_domain=0 in_hosted_domain_s3website=0 s->info.domain= s->info.request_uri=/admin/bucket
2019-08-20T14:31:19.211+0000 7f92b3518700 10 handler=17RGWHandler_Bucket
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s getting op 0
2019-08-20T14:31:19.211+0000 7f92b3518700 10 req 14 0s :get_bucket_info scheduling with dmclock client=0 cost=1
2019-08-20T14:31:19.211+0000 7f92b3518700 10 op=17RGWOp_Bucket_Info
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info verifying requester
2019-08-20T14:31:19.211+0000 7f92b3518700 20 req 14 0s :get_bucket_info rgw::auth::StrategyRegistry::s3_main_strategy_t: trying rgw::auth::s3::AWSAuthStrategy
2019-08-20T14:31:19.211+0000 7f92b3518700 20 req 14 0s :get_bucket_info rgw::auth::s3::AWSAuthStrategy: trying rgw::auth::s3::S3AnonymousEngine
2019-08-20T14:31:19.211+0000 7f92b3518700 20 req 14 0s :get_bucket_info rgw::auth::s3::S3AnonymousEngine denied with reason=-1
2019-08-20T14:31:19.211+0000 7f92b3518700 20 req 14 0s :get_bucket_info rgw::auth::s3::AWSAuthStrategy: trying rgw::auth::s3::LocalEngine
2019-08-20T14:31:19.211+0000 7f92b3518700 10 get_canon_resource(): dest=/admin/bucket
2019-08-20T14:31:19.211+0000 7f92b3518700 10 req 14 0s string_to_sign:
GET

Tue, 20 Aug 2019 14:31:19 GMT
/admin/bucket
2019-08-20T14:31:19.211+0000 7f92b3518700 15 req 14 0s :get_bucket_info string_to_sign=GET

Tue, 20 Aug 2019 14:31:19 GMT
/admin/bucket
2019-08-20T14:31:19.211+0000 7f92b3518700 15 req 14 0s :get_bucket_info server signature=bfww17S8wccruc0Uz75x5y6mE1E=
2019-08-20T14:31:19.211+0000 7f92b3518700 15 req 14 0s :get_bucket_info client signature=bfww17S8wccruc0Uz75x5y6mE1E=
2019-08-20T14:31:19.211+0000 7f92b3518700 15 req 14 0s :get_bucket_info compare=0
2019-08-20T14:31:19.211+0000 7f92b3518700 20 req 14 0s :get_bucket_info rgw::auth::s3::LocalEngine granted access
2019-08-20T14:31:19.211+0000 7f92b3518700 20 req 14 0s :get_bucket_info rgw::auth::s3::AWSAuthStrategy granted access
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info normalizing buckets and tenants
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info init permissions
2019-08-20T14:31:19.211+0000 7f92b3518700 20 get_system_obj_state: rctx=0x55fa5f6def98 obj=default.rgw.meta:users.uid:admin state=0x55fa5f731840 s->prefetch_data=0
2019-08-20T14:31:19.211+0000 7f92b3518700 10 cache get: name=default.rgw.meta+users.uid+admin : hit (requested=0x6, cached=0x17)
2019-08-20T14:31:19.211+0000 7f92b3518700 20 get_system_obj_state: s->obj_tag was set empty
2019-08-20T14:31:19.211+0000 7f92b3518700 20 Read xattr: user.rgw.idtag
2019-08-20T14:31:19.211+0000 7f92b3518700 10 cache get: name=default.rgw.meta+users.uid+admin : hit (requested=0x3, cached=0x17)
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info recalculating target
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info reading permissions
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info init op
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info verifying op mask
2019-08-20T14:31:19.211+0000 7f92b3518700 20 req 14 0s :get_bucket_info required_mask= 0 user.op_mask=7
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info verifying op permissions
2019-08-20T14:31:19.211+0000 7f92b3518700  2 overriding permissions due to system operation
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info verifying op params
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info pre-executing
2019-08-20T14:31:19.211+0000 7f92b3518700  2 req 14 0s :get_bucket_info executing
2019-08-20T14:31:19.211+0000 7f92b3518700 20 get_system_obj_state: rctx=0x55fa5f6df910 obj=default.rgw.meta:root:teuth-test-bucket state=0x55fa5f731840 s->prefetch_data=0
2019-08-20T14:31:19.211+0000 7f92b3518700 10 cache get: name=default.rgw.meta+root+teuth-test-bucket : miss
2019-08-20T14:31:19.211+0000 7f92b3518700 20 WARNING: blocking librados call
2019-08-20T14:31:19.211+0000 7f92b3518700  1 -- 172.20.0.2:0/1405484245 --> [v2:172.20.0.2:6810/1916,v1:172.20.0.2:6811/1916] -- osd_op(unknown.0.0:333 3.4 3:275246a9:root::teuth-test-bucket:head [getxattrs,stat] snapc 0=[] ondisk+read+known_if_redirected e32) v8 -- 0x55fa5f6ce840 con 0x55fa5f31c000
2019-08-20T14:31:19.212+0000 7f92e7580700  1 -- 172.20.0.2:0/1405484245 <== osd.1 v2:172.20.0.2:6810/1916 113 ==== osd_op_reply(333 teuth-test-bucket [getxattrs,stat] v0'0 uv0 ondisk = -2 ((2) No such file or directory)) v8 ==== 203+0+0 (crc 0 0 0) 0x55fa5f6e2000 con 0x55fa5f31c000
2019-08-20T14:31:19.212+0000 7f92b3518700 10 cache put: name=default.rgw.meta+root+teuth-test-bucket info.flags=0x0
2019-08-20T14:31:19.212+0000 7f92b3518700 10 adding default.rgw.meta+root+teuth-test-bucket to cache LRU end
2019-08-20T14:31:19.212+0000 7f92b3518700  2 req 14 0.000999988s :get_bucket_info completing
2019-08-20T14:31:19.212+0000 7f92b3518700  2 req 14 0.000999988s :get_bucket_info op status=0
2019-08-20T14:31:19.212+0000 7f92b3518700  2 req 14 0.000999988s :get_bucket_info http status=200
2019-08-20T14:31:19.212+0000 7f92b3518700  1 ====== req done req=0x55fa5f6e08e0 op status=0 http_status=200 latency=0.000999988s ======

#5 Updated by Casey Bodley 12 months ago

  • Related to Bug #41355: RGWOp_Bucket_Info responds with an empty body instead of reporting errors added

#6 Updated by Casey Bodley 12 months ago

  • Status changed from 12 to 7
  • Assignee deleted (Marcus Watts)
  • Pull request ID set to 29815

#7 Updated by Casey Bodley 12 months ago

  • Status changed from 7 to Resolved

#8 Updated by Kiefer Chang 12 months ago

Thanks,I ran tasks.mgr.dashboard.test_rgw.RgwBucketTest locally and it passed.

#9 Updated by Alfonso Martínez 11 months ago

  • % Done changed from 0 to 100

Also available in: Atom PDF