Project

General

Profile

Bug #41296

ceph-test RPM not built for SUSE

Added by Nathan Cutler almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://github.com/ceph/ceph/commits/0f347b82ef26e1fd776b44c4a4d05800aa06c3c6 introduced the "ceph_test_package" bcond and disabled it for SUSE builds, since upstream was not doing any SUSE builds. (This bcond is used to selectively enable and disable the ceph-test RPM in the openSUSE Build Service, since the ceph-test RPM is only needed for certain builds there.)

Now that there is a prospect of having SUSE builds upstream, this bcond needs to be activated even for SUSE builds.


Related issues

Copied to Ceph - Backport #41332: mimic: ceph-test RPM not built for SUSE Resolved
Copied to Ceph - Backport #41333: nautilus: ceph-test RPM not built for SUSE Resolved
Copied to Ceph - Backport #41334: luminous: ceph-test RPM not built for SUSE Resolved

History

#1 Updated by Nathan Cutler almost 2 years ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 29685

#2 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler almost 2 years ago

#4 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #41333: nautilus: ceph-test RPM not built for SUSE added

#5 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #41334: luminous: ceph-test RPM not built for SUSE added

#6 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved".

Also available in: Atom PDF