Project

General

Profile

Bug #41295

batch functional idempotency test fails since message is now on stderr

Added by Jan Fajerski almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

TASK [ensure batch create is idempotent] ***************************************
task path: /home/jenkins-build/build/workspace/ceph-volume-prs-batch-centos7-filestore-mixed_type/src/ceph-volume/ceph_volume/tests/functional/batch/centos7/filestore/mixed-type/test.yml:37
changed: [osd0] => {
    "changed": true, 
    "cmd": [
        "ceph-volume", 
        "--cluster", 
        "test", 
        "lvm", 
        "batch", 
        "--yes", 
        "--filestore", 
        "/dev/sdb", 
        "/dev/sdc", 
        "/dev/nvme0n1", 
        "/dev/nvme1n1" 
    ], 
    "delta": "0:00:00.657608", 
    "end": "2019-08-15 10:42:21.720532", 
    "failed_when_result": false, 
    "rc": 1, 
    "start": "2019-08-15 10:42:21.062924" 
}

STDERR:

--> Aborting because strategy changed from filestore.MixedType to filestore.SingleType after filtering

MSG:

non-zero return code

TASK [check batch idempotency] *************************************************
task path: /home/jenkins-build/build/workspace/ceph-volume-prs-batch-centos7-filestore-mixed_type/src/ceph-volume/ceph_volume/tests/functional/batch/centos7/filestore/mixed-type/test.yml:44
fatal: [osd0]: FAILED! => {
    "changed": false
}

MSG:

lvm batch failed idempotency check

Related issues

Copied to ceph-volume - Backport #41298: mimic: batch functional idempotency test fails since message is now on stderr Resolved
Copied to ceph-volume - Backport #41299: nautilus: batch functional idempotency test fails since message is now on stderr Resolved
Copied to ceph-volume - Backport #41373: luminous: batch functional idempotency test fails since message is now on stderr Resolved

History

#1 Updated by Jan Fajerski almost 2 years ago

  • Status changed from New to Pending Backport
  • Backport set to nautilus, mimic
  • Pull request ID set to 29684

#2 Updated by Jan Fajerski almost 2 years ago

  • Copied to Backport #41298: mimic: batch functional idempotency test fails since message is now on stderr added

#3 Updated by Jan Fajerski almost 2 years ago

  • Copied to Backport #41299: nautilus: batch functional idempotency test fails since message is now on stderr added

#4 Updated by Jan Fajerski almost 2 years ago

  • Status changed from Pending Backport to Resolved

#5 Updated by Jan Fajerski almost 2 years ago

  • Backport changed from nautilus, mimic to nautilus, mimic, luminous

#6 Updated by Jan Fajerski almost 2 years ago

  • Status changed from Resolved to Pending Backport

#7 Updated by Jan Fajerski almost 2 years ago

  • Copied to Backport #41373: luminous: batch functional idempotency test fails since message is now on stderr added

#8 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved".

Also available in: Atom PDF