Project

General

Profile

Bug #41205

mgr/dashboard: Access control database does not restore disabled users correctly

Added by Volker Theile 3 months ago. Updated 3 months ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Category:
dashboard/usermgmt
Target version:
Start date:
08/12/2019
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The database does not load disabled users correctly, thus a disabled user is always loaded from db with enabled=True.

It seems the issue has not been identified until now because you need to restart the dashboard module to hit the bug.


Related issues

Copied to mgr - Backport #41598: nautilus: mgr/dashboard: Access control database does not restore disabled users correctly New

History

#1 Updated by Volker Theile 3 months ago

  • Description updated (diff)

#2 Updated by Volker Theile 3 months ago

  • Status changed from New to Need Review
  • Pull request ID set to 29614

#3 Updated by Volker Theile 3 months ago

  • Description updated (diff)

#4 Updated by Kefu Chai 3 months ago

  • Status changed from Need Review to Resolved

#5 Updated by Volker Theile 3 months ago

  • Backport set to nautilus

#6 Updated by Volker Theile 3 months ago

  • Status changed from Resolved to Pending Backport

#7 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #41598: nautilus: mgr/dashboard: Access control database does not restore disabled users correctly added

Also available in: Atom PDF