Project

General

Profile

Bug #41191

osd: scrub error on big objects; make bluestore refuse to start on big objects

Added by Neha Ojha over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous,mimic,nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Related issues

Copied to RADOS - Backport #41918: mimic: osd: scrub error on big objects; make bluestore refuse to start on big objects Resolved
Copied to RADOS - Backport #41919: luminous: osd: scrub error on big objects; make bluestore refuse to start on big objects Resolved
Copied to RADOS - Backport #41920: nautilus: osd: scrub error on big objects; make bluestore refuse to start on big objects Resolved

History

#1 Updated by Neha Ojha over 3 years ago

  • Status changed from Fix Under Review to Pending Backport

#2 Updated by Nathan Cutler over 3 years ago

  • Copied to Backport #41918: mimic: osd: scrub error on big objects; make bluestore refuse to start on big objects added

#3 Updated by Nathan Cutler over 3 years ago

  • Copied to Backport #41919: luminous: osd: scrub error on big objects; make bluestore refuse to start on big objects added

#4 Updated by Nathan Cutler over 3 years ago

  • Copied to Backport #41920: nautilus: osd: scrub error on big objects; make bluestore refuse to start on big objects added

#5 Updated by Florian Haas over 3 years ago

As far as I can see, without this patch there is no way to detect excessively large objects other than doing rados stat on every object in all pools, which is frequently rather impractical. Hence my question: is there an estimate as to when the backports might land, at least the one for Nautilus?

#6 Updated by Nathan Cutler over 3 years ago

@Florian - backports on the way. I'll try to keep my eye on them.

#7 Updated by Florian Haas over 3 years ago

Thanks! It looks like the backport for Mimic has already landed while the one for Nautilus is still pending. That strikes me as unusual; was this intentional or an omission?

#8 Updated by Nathan Cutler over 3 years ago

@Florian - the explanation is simple: we're working on mimic now. We currently don't have any policy saying "fix X must not go into release Y before release Z".

#9 Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF