Project

General

Profile

Bug #41144

mount.ceph: doesn't accept "strictatime"

Added by Jeff Layton 6 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
kceph
Labels (FS):
Pull request ID:
Crash signature:

Description

The cephfs mount helper doesn't support either strictatime or nostrictatime. It should intercept those options and set/clear MS_STRICTATIME.


Related issues

Copied to fs - Backport #41465: nautilus: mount.ceph: doesn't accept "strictatime" Resolved
Copied to fs - Backport #41466: mimic: mount.ceph: doesn't accept "strictatime" Resolved

History

#1 Updated by Jeff Layton 6 months ago

  • Subject changed from mount.ceph doesn't accept "strictatime" or "nostrictatime" to mount.ceph doesn't accept "strictatime"

Changing subject. "nostrictatime" seems to be intercepted by /bin/mount, so the mount helper doesn't need to handle it.

#2 Updated by Patrick Donnelly 6 months ago

  • Project changed from Linux kernel client to fs
  • Subject changed from mount.ceph doesn't accept "strictatime" to mount.ceph: doesn't accept "strictatime"
  • Status changed from New to Pending Backport
  • Target version set to v15.0.0
  • Start date deleted (08/06/2019)
  • Source set to Development
  • Backport set to nautilus,mimic
  • Pull request ID set to 29518
  • Component(FS) kceph added

#3 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #41465: nautilus: mount.ceph: doesn't accept "strictatime" added

#4 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #41466: mimic: mount.ceph: doesn't accept "strictatime" added

#5 Updated by Nathan Cutler 4 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF