Project

General

Profile

Bug #41069

nautilus: test_subvolume_group_create_with_desired_mode fails with "AssertionError: '755' != '777'"

Added by Venky Shankar almost 2 years ago. Updated 12 months ago.

Status:
Need More Info
Priority:
High
Category:
-
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Seen here is nautilus run: http://qa-proxy.ceph.com/teuthology/yuriw-2019-07-30_20:57:10-fs-wip-yuri-testing-2019-07-30-1543-nautilus-testing-basic-smithi/4165630/teuthology.log

2019-07-31T01:04:51.292 INFO:tasks.cephfs_test_runner:
2019-07-31T01:04:51.293 INFO:tasks.cephfs_test_runner:======================================================================
2019-07-31T01:04:51.293 INFO:tasks.cephfs_test_runner:FAIL: test_subvolume_group_create_with_desired_mode (tasks.cephfs.test_volumes.TestVolumes)
2019-07-31T01:04:51.293 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-07-31T01:04:51.293 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-07-31T01:04:51.293 INFO:tasks.cephfs_test_runner: File "/home/teuthworker/src/github.com_ceph_ceph-c_wip-yuri-testing-2019-07-30-1543-nautilus/qa/tasks/cephfs/test_volumes.py", line 252, in test_subvolume_group_create_with_desired_mode
2019-07-31T01:04:51.293 INFO:tasks.cephfs_test_runner: self.assertEqual(actual_mode2, expected_mode2)
2019-07-31T01:04:51.294 INFO:tasks.cephfs_test_runner:AssertionError: '755' != '777'

History

#1 Updated by Patrick Donnelly almost 2 years ago

  • Priority changed from Normal to Immediate
  • Target version changed from v14.2.3 to v15.0.0
  • Start date deleted (08/05/2019)

#2 Updated by Ramana Raja almost 2 years ago

  • Status changed from New to Closed

The test passed in a more recent nautilus test run that included the mgr/volumes backport PR https://github.com/ceph/ceph/pull/29490,

mgr/volumes test run where the test passed
http://pulpito.ceph.com/pdonnell-2019-08-07_18:55:52-fs-wip-pdonnell-testing-20190807.161917-nautilus-distro-basic-smithi/

We can re-open this bug if it's hit again.

#3 Updated by Ramana Raja about 1 year ago

  • Subject changed from test_subvolume_group_create_with_desired_mode fails with "AssertionError: '755' != '777'" to nautilus: test_subvolume_group_create_with_desired_mode fails with "AssertionError: '755' != '777'"
  • Status changed from Closed to New
  • Assignee changed from Ramana Raja to Kotresh Hiremath Ravishankar
  • Priority changed from Immediate to High
  • Target version changed from v15.0.0 to v14.2.11
  • Source changed from Community (dev) to Q/A

I see this in a recent nautilus run during 14.2.11 pre-release testing,
http://pulpito.front.sepia.ceph.com/rraja-2020-07-29_07:09:52-fs-ajarr-nautilus-testing-2020-07-27-distro-basic-smithi/5266928/
Note: The testing branch did not include the fix for https://tracker.ceph.com/issues/46641 (qa: name collision)

#4 Updated by Kotresh Hiremath Ravishankar 12 months ago

The code looks ok both on master and nautilus branch. I ran 1000 iterations on master but didn't see the failure. I will try once on the nautilus branch.

#5 Updated by Kotresh Hiremath Ravishankar 12 months ago

Tried 1k iterations on nautilus 14.2.11 but could not reproduce.

#6 Updated by Patrick Donnelly 12 months ago

  • Status changed from New to Need More Info
  • Target version deleted (v14.2.11)
  • Affected Versions v14.2.11 added

Let's leave this as NI and see what the new debugging for mgr/volumes shows if it comes up again.

Also available in: Atom PDF