Project

General

Profile

Actions

Bug #41016

closed

Improve upmap change reporting in logs

Added by Vikhyat Umrao over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
David Zafman
Category:
-
Target version:
-
% Done:

0%

Source:
Support
Tags:
Backport:
nautilus, mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

1. do not silently skip mappings in _apply_upmap() or anywhere else, when they aren't going to be applied
2. maybe_remove_pg_upmaps() should report why upmap mappings are getting removed

RHBZ - https://bugzilla.redhat.com/show_bug.cgi?id=1734583


Related issues 3 (0 open3 closed)

Copied to RADOS - Backport #43650: nautilus: Improve upmap change reporting in logsResolvedNathan CutlerActions
Copied to RADOS - Backport #43651: luminous: Improve upmap change reporting in logsResolvedActions
Copied to RADOS - Backport #43652: mimic: Improve upmap change reporting in logsResolvedNathan CutlerActions
Actions #1

Updated by David Zafman about 4 years ago

  • Assignee set to David Zafman

The function _apply_upmap() would be getting called very frequently. This makes logging there problematic. Also, one case is transitory (OSD happens to be out). The logging would have to be greater than level 20.

The function maybe_remove_pg_upmaps() is now clean_pg_upmaps(). I see some messages that would be logged (level 0) in the osd's log for errors found in upmaps. Those messages are generated by OSDMap::check_pg_upmaps(). Some of the errors aren't logged, so we could add those.

Actions #2

Updated by David Zafman about 4 years ago

  • Status changed from New to In Progress
  • Priority changed from Normal to Immediate
  • Backport set to nautilus, mimic, luminous
Actions #3

Updated by David Zafman about 4 years ago

We aren't going to add logging to _apply_upmap() because it is invasive to get a CephContext into that function to be able to log.

Actions #4

Updated by David Zafman about 4 years ago

  • Pull request ID set to 32663
Actions #5

Updated by David Zafman about 4 years ago

  • Status changed from In Progress to Pending Backport
Actions #6

Updated by David Zafman about 4 years ago

  • Copied to Backport #43650: nautilus: Improve upmap change reporting in logs added
Actions #7

Updated by David Zafman about 4 years ago

  • Copied to Backport #43651: luminous: Improve upmap change reporting in logs added
Actions #8

Updated by David Zafman about 4 years ago

  • Copied to Backport #43652: mimic: Improve upmap change reporting in logs added
Actions #9

Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Actions

Also available in: Atom PDF