Project

General

Profile

Bug #40995

rgw dns name is not case sensitive

Added by Abhishek Lekshmanan about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

RGW incorrectly handles requests when cases do not match rgw dns name, even though dns hostnames are supposed to be case insensitive.

For eg. curl RGWHOST vs curl rgwhost incorrectly returns bucket not found in teh former as it tries to match RGWHOST against rgw_dns_name


Related issues

Related to rgw - Bug #41692: rgw dns name matching broken Resolved 09/06/2019
Copied to rgw - Backport #41478: mimic: rgw dns name is not case sensitive Resolved
Copied to rgw - Backport #41479: nautilus: rgw dns name is not case sensitive Resolved
Copied to rgw - Backport #41480: luminous: rgw dns name is not case sensitive Resolved

History

#1 Updated by Abhishek Lekshmanan about 1 year ago

  • Status changed from New to In Progress
  • Pull request ID set to 29380

#2 Updated by Abhishek Lekshmanan about 1 year ago

  • Status changed from In Progress to 7

#3 Updated by Casey Bodley about 1 year ago

  • Status changed from 7 to Pending Backport

#4 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #41478: mimic: rgw dns name is not case sensitive added

#5 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #41479: nautilus: rgw dns name is not case sensitive added

#6 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #41480: luminous: rgw dns name is not case sensitive added

#7 Updated by Casey Bodley about 1 year ago

  • Related to Bug #41692: rgw dns name matching broken added

#8 Updated by Nathan Cutler about 1 year ago

backports waiting for #41692 to enter "Pending Backport" status, since it needs to be done together with this one

#9 Updated by Casey Bodley about 1 year ago

https://tracker.ceph.com/issues/41692 is now pending backport, and its fix can be included with these backports

#10 Updated by Nathan Cutler 12 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF