Project

General

Profile

Bug #40973

mgr/dashboard: ceph-mgr-dashboard RPM contains duplicated files that are not hard- or symlinks

Added by Nathan Cutler 7 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/build
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

In the openSUSE Build Service, RPMLINT complains:

[16139s] ceph-mgr-dashboard.noarch: E: files-duplicated-waste (Badness: 100) 644061
[16139s] Your package contains duplicated files that are not hard- or symlinks. You
[16139s] should use the %fdupes macro to link the files to one.

(Note: this is becoming more and more of a problem - many OBS build workers do not have enough disk space to build ceph.)


Related issues

Copied to mgr - Backport #41091: nautilus: mgr/dashboard: ceph-mgr-dashboard RPM contains duplicated files that are not hard- or symlinks Resolved

History

#1 Updated by Nathan Cutler 7 months ago

  • Backport set to nautilus

#2 Updated by Nathan Cutler 7 months ago

  • Description updated (diff)

#3 Updated by Nathan Cutler 7 months ago

  • Category set to dashboard/general

#4 Updated by Nathan Cutler 7 months ago

  • Category changed from dashboard/general to dashboard/build

#5 Updated by Nathan Cutler 7 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 29346

#6 Updated by Kefu Chai 7 months ago

  • Status changed from Fix Under Review to Pending Backport

#7 Updated by Patrick Donnelly 7 months ago

  • Copied to Backport #41091: nautilus: mgr/dashboard: ceph-mgr-dashboard RPM contains duplicated files that are not hard- or symlinks added

#8 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF