Project

General

Profile

Bug #40825

test_osd_came_back (tasks.mgr.test_progress.TestProgress) ... FAIL

Added by Sage Weil over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

the test marks osd out, verifies a progress event is there, then marks it in, and asserts that there are no progress events.

But.. now there is (sometimes) a 'marked in' event:

2019-07-18T19:12:29.219 INFO:teuthology.orchestra.run.smithi091.stdout:{
2019-07-18T19:12:29.219 INFO:teuthology.orchestra.run.smithi091.stdout:  "completed": [
2019-07-18T19:12:29.220 INFO:teuthology.orchestra.run.smithi091.stdout:    {
2019-07-18T19:12:29.220 INFO:teuthology.orchestra.run.smithi091.stdout:      "duration": "(since 00h 00m 00s)",
2019-07-18T19:12:29.220 INFO:teuthology.orchestra.run.smithi091.stdout:      "message": "Rebalancing after osd.0 marked out",
2019-07-18T19:12:29.220 INFO:teuthology.orchestra.run.smithi091.stdout:      "id": "b6651449-58b7-4893-a2b7-6804e0ddf494",
2019-07-18T19:12:29.220 INFO:teuthology.orchestra.run.smithi091.stdout:      "refs": [
2019-07-18T19:12:29.220 INFO:teuthology.orchestra.run.smithi091.stdout:        [
2019-07-18T19:12:29.220 INFO:teuthology.orchestra.run.smithi091.stdout:          "osd",
2019-07-18T19:12:29.221 INFO:teuthology.orchestra.run.smithi091.stdout:          0
2019-07-18T19:12:29.221 INFO:teuthology.orchestra.run.smithi091.stdout:        ]
2019-07-18T19:12:29.221 INFO:teuthology.orchestra.run.smithi091.stdout:      ]
2019-07-18T19:12:29.221 INFO:teuthology.orchestra.run.smithi091.stdout:    }
2019-07-18T19:12:29.221 INFO:teuthology.orchestra.run.smithi091.stdout:  ],
2019-07-18T19:12:29.221 INFO:teuthology.orchestra.run.smithi091.stdout:  "events": [
2019-07-18T19:12:29.221 INFO:teuthology.orchestra.run.smithi091.stdout:    {
2019-07-18T19:12:29.222 INFO:teuthology.orchestra.run.smithi091.stdout:      "duration": "(since 00h 00m 00s)",
2019-07-18T19:12:29.222 INFO:teuthology.orchestra.run.smithi091.stdout:      "message": "Rebalancing after osd.0 marked in",
2019-07-18T19:12:29.222 INFO:teuthology.orchestra.run.smithi091.stdout:      "id": "c13924d3-b555-4bca-896b-e165fb078401",
2019-07-18T19:12:29.222 INFO:teuthology.orchestra.run.smithi091.stdout:      "refs": [
2019-07-18T19:12:29.222 INFO:teuthology.orchestra.run.smithi091.stdout:        [
2019-07-18T19:12:29.222 INFO:teuthology.orchestra.run.smithi091.stdout:          "osd",
2019-07-18T19:12:29.222 INFO:teuthology.orchestra.run.smithi091.stdout:          0
2019-07-18T19:12:29.222 INFO:teuthology.orchestra.run.smithi091.stdout:        ]
2019-07-18T19:12:29.223 INFO:teuthology.orchestra.run.smithi091.stdout:      ]
2019-07-18T19:12:29.223 INFO:teuthology.orchestra.run.smithi091.stdout:    }
2019-07-18T19:12:29.223 INFO:teuthology.orchestra.run.smithi091.stdout:  ]

/a/sage-2019-07-18_18:30:47-rados-wip-sage-testing-2019-07-18-0952-distro-basic-smithi/4126836


Related issues

Duplicates mgr - Bug #40618: Test failure: test_osd_came_back (tasks.mgr.test_progress.TestProgress) Resolved 07/02/2019

History

#1 Updated by Josh Durgin over 1 year ago

  • Status changed from 12 to 7
  • Pull request ID set to 29111

#2 Updated by Sage Weil over 1 year ago

2019-07-23T19:56:20.700 INFO:tasks.cephfs_test_runner:======================================================================
2019-07-23T19:56:20.700 INFO:tasks.cephfs_test_runner:ERROR: test_osd_came_back (tasks.mgr.test_progress.TestProgress)
2019-07-23T19:56:20.701 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-07-23T19:56:20.701 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-07-23T19:56:20.701 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-sage-testing-2019-07-23-0925/qa/tasks/mgr/test_progress.py", line 202, in test_osd_came_back
2019-07-23T19:56:20.701 INFO:tasks.cephfs_test_runner:    ev2 = self._simulate_back_in([0], ev1)
2019-07-23T19:56:20.701 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-sage-testing-2019-07-23-0925/qa/tasks/mgr/test_progress.py", line 134, in _simulate_back_in
2019-07-23T19:56:20.701 INFO:tasks.cephfs_test_runner:    return ev
2019-07-23T19:56:20.701 INFO:tasks.cephfs_test_runner:NameError: global name 'ev' is not defined

/a/sage-2019-07-23_18:50:19-rados-wip-sage-testing-2019-07-23-0925-distro-basic-smithi/4142366

#3 Updated by Kefu Chai over 1 year ago

  • Status changed from 7 to Duplicate

#4 Updated by Kefu Chai over 1 year ago

  • Duplicates Bug #40618: Test failure: test_osd_came_back (tasks.mgr.test_progress.TestProgress) added

Also available in: Atom PDF