Project

General

Profile

Bug #40800

ceph_volume_client: to_bytes converts NoneType object str

Added by Rishabh Dave 12 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
VolumeClient
Labels (FS):
Pull request ID:
Crash signature:

Description

Precisely, it happens here - https://github.com/ceph/ceph/blob/master/src/pybind/ceph_volume_client.py#L29-L32

IMO, to_bytes should just return None instead of returning "None".

I'll add fix for this to PR #28557 since it's blocked due this bug.


Related issues

Copied to fs - Backport #40886: mimic: ceph_volume_client: to_bytes converts NoneType object str Rejected
Copied to fs - Backport #40887: nautilus: ceph_volume_client: to_bytes converts NoneType object str Resolved

History

#1 Updated by Rishabh Dave 12 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 28557

#2 Updated by Patrick Donnelly 12 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Target version set to v15.0.0
  • Source set to Development
  • Backport set to nautilus,mimic

#3 Updated by Nathan Cutler 12 months ago

  • Copied to Backport #40886: mimic: ceph_volume_client: to_bytes converts NoneType object str added

#4 Updated by Nathan Cutler 12 months ago

  • Copied to Backport #40887: nautilus: ceph_volume_client: to_bytes converts NoneType object str added

#5 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF