Project

General

Profile

Bug #40776

Devices with size <5GB should not be available

Added by Jan Fajerski 9 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

This bug came up on a system with an MDRaid configuration. One raid volume is reported with size 0 but nonetheless it is marked as available by util/device.py.

I would argue we should mark any devices smaller than 5GB as unavailable, since c-v won't create any volumes on those anyway. At the very least it seems we need to check for size>0.


Related issues

Duplicated by Orchestrator - Feature #39057: orchestrator_cli should check minimum device size Duplicate
Copied to ceph-volume - Backport #42703: nautilus: Devices with size <5GB should not be available Resolved
Copied to ceph-volume - Backport #42704: mimic: Devices with size <5GB should not be available Resolved

History

#2 Updated by Sebastian Wagner 5 months ago

  • Duplicated by Feature #39057: orchestrator_cli should check minimum device size added

#3 Updated by Sebastian Wagner 5 months ago

  • Pull request ID set to 29041

#4 Updated by Jan Fajerski 5 months ago

  • Backport set to nautilus, mimic

#5 Updated by Jan Fajerski 5 months ago

  • Status changed from New to Pending Backport

#6 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #42703: nautilus: Devices with size <5GB should not be available added

#7 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #42704: mimic: Devices with size <5GB should not be available added

#8 Updated by Jan Fajerski 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF