Project

General

Profile

Bug #40583

Lower the default value of osd_deep_scrub_large_omap_object_key_threshold

Added by Neha Ojha about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous,mimic,nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The current default of 2million k/v pairs is too high. Recovery takes too long
for bucket index objects with this much omap data in particular, which blocks
access to client buckets until it completes.

Lower the default for osd_deep_scrub_large_omap_object_key_threshold so such
objects can be detected before they become a problem


Related issues

Related to CephFS - Bug #42515: fs: OpenFileTable object shards have too many k/v pairs Resolved
Copied to RADOS - Backport #40653: luminous: Lower the default value of osd_deep_scrub_large_omap_object_key_threshold Resolved
Copied to RADOS - Backport #40654: mimic: Lower the default value of osd_deep_scrub_large_omap_object_key_threshold Resolved
Copied to RADOS - Backport #40655: nautilus: Lower the default value of osd_deep_scrub_large_omap_object_key_threshold Resolved

History

#1 Updated by Neha Ojha about 2 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Neha Ojha
  • Pull request ID set to 28782

#2 Updated by Sage Weil about 2 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #40653: luminous: Lower the default value of osd_deep_scrub_large_omap_object_key_threshold added

#4 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #40654: mimic: Lower the default value of osd_deep_scrub_large_omap_object_key_threshold added

#5 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #40655: nautilus: Lower the default value of osd_deep_scrub_large_omap_object_key_threshold added

#6 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved".

#7 Updated by Patrick Donnelly almost 2 years ago

  • Related to Bug #42515: fs: OpenFileTable object shards have too many k/v pairs added

#8 Updated by Florian Haas almost 2 years ago

I am taking the liberty to add a couple of recent mailing list threads here that highlight a potentially unintended consequence of this change, all related to the radosgw usage log, in the hope that it'll make it easier for people to make the connection:

Also available in: Atom PDF