Project

General

Profile

Bug #40557

Rocksdb lookups slow until manual compaction

Added by Greg Farnum about 2 months ago. Updated about 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
06/26/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

https://www.spinics.net/lists/ceph-users/msg53623.html
"[ceph-users] OSDs taking a long time to boot due to 'clear_temp_objects', even with fresh PGs"

I'm guessing this is due to a combination of RocksDB not being compacted to clear out many deleted objects, and the lookup issue fixed in github.com/ceph/ceph/pull/27627

ceph-post-file: 1829bf40-cce1-4f65-8b35-384935d11446

History

#1 Updated by Igor Fedotov about 2 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF