Project

General

Profile

Bug #40526

rgw: deleting bucket can fail when it contains unfinished multipart uploads

Added by J. Eric Ivancich over 1 year ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus,mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

As part of the process of deleting a bucket, all underway multipart uploads are aborted and their artifacts are cleaned up. This is done in blocks, and as long as the current block indicates that it is not the final block (i.e., is_truncated) it will fetch another block.

If the final block indicates it could not find the artifacts it wanted to clean up, the process fails and causes bucket deletion to fail. This does not happen if the final block succeeds and previous blocks have this error.

Since this should be a best-effort process, the inability to find artifacts should not prevent bucket deletion from completing.


Related issues

Copied to rgw - Backport #40589: luminous: rgw: deleting bucket can fail when it contains unfinished multipart uploads Rejected
Copied to rgw - Backport #40590: mimic: rgw: deleting bucket can fail when it contains unfinished multipart uploads Resolved
Copied to rgw - Backport #40591: nautilus: rgw: deleting bucket can fail when it contains unfinished multipart uploads Resolved

History

#1 Updated by J. Eric Ivancich over 1 year ago

  • Pull request ID set to 28742

#2 Updated by J. Eric Ivancich over 1 year ago

  • Pull request ID changed from 28742 to 28724

#3 Updated by J. Eric Ivancich over 1 year ago

  • Description updated (diff)

#4 Updated by Casey Bodley over 1 year ago

  • Status changed from In Progress to Pending Backport

#5 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #40589: luminous: rgw: deleting bucket can fail when it contains unfinished multipart uploads added

#6 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #40590: mimic: rgw: deleting bucket can fail when it contains unfinished multipart uploads added

#7 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #40591: nautilus: rgw: deleting bucket can fail when it contains unfinished multipart uploads added

#9 Updated by J. Eric Ivancich 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF