Project

General

Profile

Bug #40429

mgr/volumes: subvolume.py calls Exceptions with too few arguments.

Added by Sebastian Wagner 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes
Labels (FS):
Pull request ID:

Description

mypy revealed

+pybind/mgr/volumes/fs/subvolume.py: note: In member "get_subvolume_path" of class "SubVolume":
+pybind/mgr/volumes/fs/subvolume.py:167: error: Too few arguments for "VolumeException" 
+pybind/mgr/volumes/fs/subvolume.py: note: In member "_get_ancestor_xattr" of class "SubVolume":
+pybind/mgr/volumes/fs/subvolume.py:203: error: Too few arguments for "NoData" 

both of these errors are actual bugs in the code and needs to get fixed.


Related issues

Copied to fs - Backport #40569: nautilus: mgr/volumes: subvolume.py calls Exceptions with too few arguments Resolved

History

#1 Updated by Sebastian Wagner 2 months ago

  • Project changed from mgr to fs
  • Component(FS) mgr/volumes added

#2 Updated by Patrick Donnelly 2 months ago

  • Priority changed from Normal to Urgent
  • Target version set to v15.0.0
  • Start date deleted (06/19/2019)

#3 Updated by Ramana Raja about 2 months ago

  • Pull request ID set to 28706

#4 Updated by Ramana Raja about 2 months ago

  • Status changed from New to Need Review

#5 Updated by Ramana Raja about 2 months ago

+pybind/mgr/volumes/fs/subvolume.py: note: In member "_get_ancestor_xattr" of class "SubVolume":

+pybind/mgr/volumes/fs/subvolume.py:203: error: Too few arguments for "NoData"

I don't get the above error, when I run `./script/run_mypy.sh` against ceph master.

#6 Updated by Sebastian Wagner about 2 months ago

Ramana Raja wrote:

+pybind/mgr/volumes/fs/subvolume.py: note: In member "_get_ancestor_xattr" of class "SubVolume":

+pybind/mgr/volumes/fs/subvolume.py:203: error: Too few arguments for "NoData"

I don't get the above error, when I run `./script/run_mypy.sh` against ceph master.

That's because mypy cannot inspect cython bindings without type hints added in

https://github.com/ceph/ceph/pull/26769/files#diff-c1f4bb1fdcc925889b5d9e38148ee07eR16

#7 Updated by Venky Shankar about 2 months ago

  • Status changed from Need Review to Pending Backport

#8 Updated by Ramana Raja about 2 months ago

  • Copied to Backport #40569: nautilus: mgr/volumes: subvolume.py calls Exceptions with too few arguments added

#9 Updated by Patrick Donnelly about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF