Project

General

Profile

Bug #40398

OBS fails to build master due to RPATH issue in libceph_crypto_isal.so.1.0.0

Added by Nathan Cutler 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

[ 2754s] CMake Error at src/crypto/isa-l/cmake_install.cmake:73 (file):
[ 2754s]   file RPATH_CHANGE could not write new RPATH:
[ 2754s] 
[ 2754s]     /usr/lib64/ceph
[ 2754s] 
[ 2754s]   to the file:
[ 2754s] 
[ 2754s]     /home/abuild/rpmbuild/BUILDROOT/ceph-15.0.0-lp151.1851.1.x86_64/usr/lib64/ceph/crypto/libceph_crypto_isal.so.1.0.0
[ 2754s] 
[ 2754s]   No valid ELF RPATH or RUNPATH entry exists in the file;
[ 2754s] Call Stack (most recent call first):
[ 2754s]   src/crypto/cmake_install.cmake:43 (include)
[ 2754s]   src/cmake_install.cmake:339 (include)
[ 2754s]   cmake_install.cmake:42 (include)
[ 2754s] 
[ 2754s] 
[ 2754s] make: *** [Makefile:85: install] Error 1
[ 2754s] error: Bad exit status from /var/tmp/rpm-tmp.Vgf5Ap (%install)

Related issues

Related to Ceph - Bug #40295: OBS fails to build master due to RPATH issue Resolved 06/12/2019

History

#1 Updated by Nathan Cutler 10 months ago

  • Related to Bug #40295: OBS fails to build master due to RPATH issue added

#2 Updated by Nathan Cutler 10 months ago

  • Status changed from New to In Progress
  • Pull request ID set to 28593

#3 Updated by Kefu Chai 10 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF