Project

General

Profile

Bug #40186

mgr/dashboard: NFS Ganesha Object Gateway exports should default to read-only and warn if RW is requested

Added by Lenz Grimmer about 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/nfs-ganesha
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The Ceph Dashboard includes a GUI for Ganesha management. The configuration UI allows users to select Object Gateway backed exports with different access modes (RO, RW, etc.).

As documented in http://docs.ceph.com/docs/master/radosgw/nfs/ , the NFS Object Gateway has a number of limitations which will seriously affect applications writing to the share:

The RGW NFS interface supports most operations on files and directories, with the following restrictions:

    Links, including symlinks, are not supported
    NFS ACLs are not supported
        Unix user and group ownership and permissions are supported
    Directories may not be moved/renamed
        files may be moved between directories
    Only full, sequential write i/o is supported
        i.e., write operations are constrained to be uploads
        many typical i/o operations such as editing files in place will necessarily fail as they perform non-sequential stores
        some file utilities apparently writing sequentially (e.g., some versions of GNU tar) may fail due to infrequent non-sequential stores
        When mounting via NFS, sequential application i/o can generally be constrained to be written sequentially to the NFS server via a synchronous mount option (e.g. -osync in Linux)
        NFS clients which cannot mount synchronously (e.g., MS Windows) will not be able to upload files

Because of these limitations, the Dashboard should configure Object Gateway Ganesha exports to be read-only by default. If write is selected, a warning should be shown with a link to the excerpt above.


Related issues

Copied to mgr - Backport #41773: nautilus: mgr/dashboard: NFS Ganesha Object Gateway exports should default to read-only and warn if RW is requested Resolved

History

#1 Updated by Lenz Grimmer about 1 year ago

  • Subject changed from NFS Ganesha Object Gateway exports should default to read-only and warn if RW is requested to mgr/dashboard: NFS Ganesha Object Gateway exports should default to read-only and warn if RW is requested

#2 Updated by Tiago Melo 10 months ago

  • Assignee set to Tiago Melo

#3 Updated by Tiago Melo 10 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 30111

#4 Updated by Lenz Grimmer 10 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Target version set to v15.0.0

#5 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #41773: nautilus: mgr/dashboard: NFS Ganesha Object Gateway exports should default to read-only and warn if RW is requested added

#6 Updated by Lenz Grimmer 8 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF