Project

General

Profile

Bug #40112

mon: rados/multimon tests fail with clock skew

Added by Sage Weil 10 months ago. Updated 6 days ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

Description

See

http://pulpito.ceph.com/sage-2019-05-30_21:14:09-rados:multimon-master-distro-basic-smithi/

or

http://pulpito.ceph.com/sage-2019-06-03_14:22:18-rados:multimon-master-distro-basic-smithi/
http://pulpito.ceph.com/sage-2019-06-03_14:24:56-rados:multimon-nautilus-distro-basic-smithi/

The second variant, where we don't see the SKEW failure, appears to be caused because the ceph setup command to set the crush tunables takes foreeever due to no quorum, but eventually the clocks correct themselves and then the job proceeds (probably NTP)?

The underlying problem appears to be that mons can't form quorum if there is too much skew, which prevents a meaningful test.

whenever mon.b is the rank 0 mon.


Related issues

Duplicated by RADOS - Bug #38893: RuntimeError: expected MON_CLOCK_SKEW but got none Resolved 03/22/2019
Copied to RADOS - Backport #40228: nautilus: mon: rados/multimon tests fail with clock skew Resolved
Copied to RADOS - Backport #44908: mimic: mon: rados/multimon tests fail with clock skew In Progress

History

#1 Updated by Sage Weil 10 months ago

  • Status changed from 12 to Pending Backport
  • Backport set to nautilus

#2 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #40228: nautilus: mon: rados/multimon tests fail with clock skew added

#3 Updated by Nathan Cutler 7 months ago

  • Pull request ID set to 28353

#4 Updated by Nathan Cutler 7 months ago

  • Duplicated by Bug #38893: RuntimeError: expected MON_CLOCK_SKEW but got none added

#5 Updated by Nathan Cutler 7 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved".

#6 Updated by Nathan Cutler 6 days ago

  • Backport changed from nautilus to nautilus, mimic

#7 Updated by Nathan Cutler 6 days ago

  • Status changed from Resolved to Pending Backport

#8 Updated by Nathan Cutler 6 days ago

  • Copied to Backport #44908: mimic: mon: rados/multimon tests fail with clock skew added

Also available in: Atom PDF