Project

General

Profile

Bug #40066

PGs not scrubbed since 0.000000

Added by David Galloway about 1 year ago. Updated almost 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The Sepia Long Running Cluster has been in HEALTH_WARN for a couple days (at least) due to PG_NOT_DEEP_SCRUBBED and PG_NOT_SCRUBBED

The number of PGs fluctuates every couple seconds.

I'm guessing there's a bug in the time calculation?

HEALTH_WARN 10 pgs not deep-scrubbed in time; 10 pgs not scrubbed in time
PG_NOT_DEEP_SCRUBBED 10 pgs not deep-scrubbed in time
    pg 92.bc3 not deep-scrubbed since 0.000000
    pg 0.b97 not deep-scrubbed since 0.000000
    pg 0.a98 not deep-scrubbed since 0.000000
    pg 0.8c1 not deep-scrubbed since 0.000000
    pg 0.73f not deep-scrubbed since 0.000000
    pg 4.5d9 not deep-scrubbed since 0.000000
    pg 0.2a6 not deep-scrubbed since 0.000000
    pg 0.1a9 not deep-scrubbed since 0.000000
    pg 0.322 not deep-scrubbed since 0.000000
    pg 0.340 not deep-scrubbed since 0.000000
PG_NOT_SCRUBBED 10 pgs not scrubbed in time
    pg 92.bc3 not scrubbed since 0.000000
    pg 0.b97 not scrubbed since 0.000000
    pg 0.a98 not scrubbed since 0.000000
    pg 0.8c1 not scrubbed since 0.000000
    pg 0.73f not scrubbed since 0.000000
    pg 4.5d9 not scrubbed since 0.000000
    pg 0.2a6 not scrubbed since 0.000000
    pg 0.1a9 not scrubbed since 0.000000
    pg 0.322 not scrubbed since 0.000000
    pg 0.340 not scrubbed since 0.000000

Related issues

Duplicates RADOS - Bug #40073: PG scrub stamps reset to 0.000000 Resolved 05/29/2019

History

#1 Updated by Nathan Cutler almost 1 year ago

  • Related to Bug #40073: PG scrub stamps reset to 0.000000 added

#2 Updated by David Zafman almost 1 year ago

  • Duplicates Bug #40073: PG scrub stamps reset to 0.000000 added

#3 Updated by David Zafman almost 1 year ago

  • Related to deleted (Bug #40073: PG scrub stamps reset to 0.000000)

#4 Updated by David Zafman almost 1 year ago

  • Status changed from New to Duplicate

Also available in: Atom PDF