Project

General

Profile

Bug #39973

"profile rbd" OSD cap should add "class rbd metadata_list" cap by default.

Added by Jason Dillaman almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Clients restricted to a namespace cannot currently open an image since it requires permission to read the pool metadata.


Related issues

Copied to rbd - Backport #40237: nautilus: "profile rbd" OSD cap should add "class rbd metadata_list" cap by default. Resolved

History

#1 Updated by wb song almost 2 years ago

*PR:*https://github.com/ceph/ceph/pull/28253

#2 Updated by Mykola Golub almost 2 years ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 28253

#3 Updated by Jason Dillaman almost 2 years ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #40237: nautilus: "profile rbd" OSD cap should add "class rbd metadata_list" cap by default. added

#5 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF