Project

General

Profile

Bug #39971

Several embedded Grafana dashboards are not displayed due to changed uids

Added by Kiefer Chang 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/monitoring
Target version:
Start date:
05/20/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Some embedded Grafana dashboards's uids were changed recently:

PR: https://github.com/ceph/ceph/pull/28043
Tracker: http://tracker.ceph.com/issues/39652

This leads to some performance data page not displayed because mismatched uid.

Also in Cluster->OSDs page: if a user clicks an OSD, the corresponding dashboard in Performance Details always refers to osd.0.


Related issues

Related to mgr - Bug #39652: Grafana dashboards use outdated metric names from the prometheus module Resolved 05/09/2019
Related to mgr - Fix #40008: mgr/dashboard: Need a method to check references to Grafana dashboards are correct or exist Need Review 05/23/2019
Copied to mgr - Backport #40006: nautilus: Several embedded Grafana dashboards are not displayed due to changed uids Resolved

History

#1 Updated by Kiefer Chang 3 months ago

  • Status changed from New to In Progress
  • Assignee set to Kiefer Chang

WIP. Also thinking if it's possible to add some checks in CI for future changes.

#2 Updated by Kiefer Chang 3 months ago

  • Pull request ID set to 28169

#3 Updated by Nathan Cutler 3 months ago

  • Status changed from In Progress to Need Review

#4 Updated by Lenz Grimmer 3 months ago

  • Backport set to nautilus
  • Regression changed from No to Yes

#5 Updated by Lenz Grimmer 3 months ago

  • Related to Bug #39652: Grafana dashboards use outdated metric names from the prometheus module added

#6 Updated by Kiefer Chang 3 months ago

As Lenz mentioned in standup, one approach to prevent this mismatch is to add e2e tests for these pages. (This requires accompanying Prometheus and Grafana instance running)

Another approach is to create a file that maintains mappings from uids in Angular template to those in Grafana dashboards. And a script is created to check those values are identical. If a developer updates Grafana dashboard with a new uid and does not update corresponding ones in Angular templates, the script should spot this.

#7 Updated by Lenz Grimmer 3 months ago

  • Status changed from Need Review to Pending Backport
  • Target version set to v15.0.0

#8 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #40006: nautilus: Several embedded Grafana dashboards are not displayed due to changed uids added

#9 Updated by Kiefer Chang 3 months ago

  • Related to Fix #40008: mgr/dashboard: Need a method to check references to Grafana dashboards are correct or exist added

#10 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF