Project

General

Profile

Bug #39933

mgr/dashboard: inconsistent result when editing a RBD image's features

Added by Kiefer Chang 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/backend
Target version:
Start date:
05/15/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Steps to reproduce:

  • Test on master commit 278f5de4126883c1fd6bd1e2c08ed8244b563928
  • Create a RBD pool
  • Create an image in that pool with only `layering` feature on
  • Edit the image, Turn on `Exclusive lock`, `Object map`, and `Fast diff` features
  • A pop-up shows: [errno 22] error updating features for image b'vol1'
  • Reload image list and found that features `layering`, `Exclusive lock`, `Object map`, and `Fast diff` are all enabled.
Some other issues:
  • Create an image with `layering` feature and later edit it with `Exclusive lock`, `Object map`: success but `Fast diff` is also on.
  • Edit an image with `layering`, `Exclusive lock`, `Object map`, and `Fast diff` feature and uncheck `Fast diff`: success but `Object map` is also off.
  • Teuthology test fails on test_image_change_features (tasks.mgr.dashboard.test_rbd.RbdTest)
# checkout 8e7be2cc4a8b7e0b5c902c1a3d16bca3c185b4f4
# source run-backend-api-tests.sh
# run_teuthology_tests tasks.mgr.dashboard.test_rbd

2019-05-15 07:30:17,802.802 INFO:__main__:======================================================================
2019-05-15 07:30:17,802.802 INFO:__main__:FAIL: test_image_change_features (tasks.mgr.dashboard.test_rbd.RbdTest)
2019-05-15 07:30:17,803.803 INFO:__main__:----------------------------------------------------------------------
2019-05-15 07:30:17,803.803 INFO:__main__:Traceback (most recent call last):
2019-05-15 07:30:17,803.803 INFO:__main__:  File "/ceph/qa/tasks/mgr/dashboard/test_rbd.py", line 492, in test_image_change_features
2019-05-15 07:30:17,803.803 INFO:__main__:    'journaling', 'layering'])
2019-05-15 07:30:17,803.803 INFO:__main__:  File "/ceph/qa/tasks/mgr/dashboard/test_rbd.py", line 215, in _validate_image
2019-05-15 07:30:17,804.804 INFO:__main__:    self.assertSetEqual(set(img[k]), set(v))
2019-05-15 07:30:17,804.804 INFO:__main__:AssertionError: Items in the second set but not the first:
2019-05-15 07:30:17,804.804 INFO:__main__:'journaling'
2019-05-15 07:30:17,804.804 INFO:__main__:
2019-05-15 07:30:17,805.805 INFO:__main__:----------------------------------------------------------------------
2019-05-15 07:30:17,805.805 INFO:__main__:Ran 14 tests in 145.670s
2019-05-15 07:30:17,805.805 INFO:__main__:
2019-05-15 07:30:17,805.805 INFO:__main__:FAILED (failures=1)

Seems there are some co-existing behavior for `object map` and `fast diff` features.

error_pop_up_when_editing.png View (247 KB) Kiefer Chang, 05/15/2019 09:07 AM

features_on.png View (99.6 KB) Kiefer Chang, 05/15/2019 09:07 AM


Related issues

Related to mgr - Feature #39451: mgr/dashboard: Interlock `fast-diff` and `object-map` Resolved 04/24/2019
Copied to mgr - Backport #39993: nautilus: mgr/dashboard: inconsistent result when editing a RBD image's features Resolved

History

#1 Updated by Kiefer Chang 3 months ago

  • Subject changed from mgr/dashboard: inconsistent result when editing a RBD image features to mgr/dashboard: inconsistent result when editing a RBD image's features

#2 Updated by Kiefer Chang 3 months ago

Related: http://tracker.ceph.com/issues/39521

Now enable/disable object-map or fast-diff will also enable/disable the other.
If we providing two features to backend, the second update_features call will fails because it's already on.

#3 Updated by Mykola Golub 3 months ago

I suppose #39451 will fix this.

#4 Updated by Patrick Seidensal 3 months ago

  • Related to Feature #39451: mgr/dashboard: Interlock `fast-diff` and `object-map` added

#5 Updated by Patrick Seidensal 3 months ago

  • Status changed from New to Verified
  • Assignee set to Patrick Seidensal

#6 Updated by Patrick Seidensal 3 months ago

  • Assignee changed from Patrick Seidensal to Kiefer Chang

#7 Updated by Kiefer Chang 3 months ago

  • Status changed from Verified to In Progress
  • Pull request ID set to 28147

#8 Updated by Laura Paduano 3 months ago

  • Status changed from In Progress to Need Review

#9 Updated by Lenz Grimmer 3 months ago

  • Status changed from Need Review to Pending Backport
  • Target version set to v15.0.0
  • Backport set to nautilus

#10 Updated by Kiefer Chang 3 months ago

  • Copied to Backport #39993: nautilus: mgr/dashboard: inconsistent result when editing a RBD image's features added

#11 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF