Project

General

Profile

Bug #39750

mgr/volumes: cannot create subvolumes with py3 libraries

Added by Ramana Raja 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volume, mgr/volumes
Labels (FS):
Pull request ID:

Description

Built ceph, master branch with python 3 enabled,

./do_cmake.sh -DBOOST_J=8 -DWITH_PYTHON3=ON -DWITH_MGR_DASHBOARD_FRONTEND=OFF -DWITH_RDMA=OFF -DWITH_RDMACM=OFF -DWITH_SPDK=OFF -DWITH_GSSAPI=OFF

After setting up vstart cluster,

build]$ ./bin/ceph fs volume ls
2019-05-14 20:56:49.374 7fa2aa35e700 -1 WARNING: all dangerous and experimental features are enabled.
2019-05-14 20:56:49.433 7fa2aa35e700 -1 WARNING: all dangerous and experimental features are enabled.
[
  {
    "name": "a" 
  }
]

Subvolume creation fails,

$ ./bin/ceph fs subvolume create a subvol1
2019-05-14 20:56:59.411 7f4d3645e700 -1 WARNING: all dangerous and experimental features are enabled.
2019-05-14 20:56:59.473 7f4d3645e700 -1 WARNING: all dangerous and experimental features are enabled.
Error EINVAL: TypeError: expected bytes, str found


Related issues

Copied to fs - Backport #40157: nautilus: mgr/volumes: cannot create subvolumes with py3 libraries Resolved

History

#1 Updated by Patrick Donnelly 3 months ago

  • Project changed from mgr to fs
  • Subject changed from mgr/volumes: cannot create subvolumes with py3 libraries to mgr/volume: cannot create subvolumes with py3 libraries
  • Category deleted (ceph-mgr)
  • Assignee set to Ramana Raja
  • Target version set to v15.0.0
  • Start date deleted (05/14/2019)
  • Backport set to nautilus
  • Component(FS) mgr/volume added

#2 Updated by Rishabh Dave 3 months ago

I can't reproduce the issue. I get the following warning when I run the do_cmake.sh as shown in the report -

CMake Warning:
Manually-specified variables were not used by the project:

WITH_RDMACM

-- Build files have been written to: /home/rishabh/repos/ceph/tracker-39750/build
+ cat
+ echo done.
done.
+ cat

#3 Updated by Rishabh Dave 3 months ago

  • Assignee changed from Ramana Raja to Rishabh Dave
  • Priority changed from Normal to Immediate

#4 Updated by Patrick Donnelly 3 months ago

  • Subject changed from mgr/volume: cannot create subvolumes with py3 libraries to mgr/volumes: cannot create subvolumes with py3 libraries
  • Description updated (diff)
  • Component(FS) mgr/volumes added

#5 Updated by Nathan Cutler 3 months ago

To successfully reproduce, -DWITH_PYTHON2=OFF may also be needed (in addition to the options shown in the bug description) and, just to be sure, run the build in an environment that does not have Python 2 installed at all.

#6 Updated by Rishabh Dave 3 months ago

  • Pull request ID set to 28380

Thanks, Nathan! I could reproduce this issue just with -DWITH_PYTHON3=ON.

#7 Updated by Rishabh Dave 3 months ago

  • Status changed from New to Need Review

#8 Updated by Patrick Donnelly 3 months ago

  • Status changed from Need Review to Pending Backport

#9 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #40157: nautilus: mgr/volumes: cannot create subvolumes with py3 libraries added

#10 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF