Project

General

Profile

Bug #39665

kstore: memory may leak on KStore::_do_read_stripe

Added by Shanchun Lv over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

On testing kstore, we found that memory leaks when execute read ops. The root cause is when execute read ops, the in-flight stripes will be cached in memory, but won't be cleared. Actually, there is no need to cache the in-flight stripes on read process, we can just discard it on read ops. The appendix is the related heap dump file.

osd0-heap-dump.png View (53.2 KB) Shanchun Lv, 05/10/2019 08:29 AM

History

#2 Updated by Neha Ojha over 3 years ago

  • Status changed from New to Fix Under Review

#3 Updated by Kefu Chai almost 3 years ago

  • Status changed from Fix Under Review to Resolved
  • Assignee set to Chang Liu
  • Pull request ID set to 32538

Also available in: Atom PDF