Project

General

Profile

Bug #39611

master/octopus FTBFS on s390x

Added by Nathan Cutler 10 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

tip of master 6455f96c49ceb49691f27f9d8604e9f5d366ed0f Fails To Build From Source (FTBFS) on s390x. Relevant log excerpt:

...
[ 1726s] [ 49%] Building CXX object src/rgw/CMakeFiles/rgw_common.dir/rgw_env.cc.o
[ 1727s] [ 49%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/Threads.cc.o
[ 1732s] [ 49%] Building CXX object src/mon/CMakeFiles/mon.dir/Elector.cc.o
[ 1736s] [ 49%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/Types.cc.o
[ 1737s] [ 49%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_deleter/RemoveRequest.cc.o
[ 1738s] [ 49%] Building CXX object src/rgw/CMakeFiles/rgw_common.dir/rgw_es_query.cc.o
[ 1743s] [ 49%] Building CXX object src/librbd/CMakeFiles/rbd_internal.dir/cache/PassthroughImageCache.cc.o
[ 1747s] [ 49%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_deleter/SnapshotPurgeRequest.cc.o
[ 1752s] [ 49%] Building CXX object src/librbd/CMakeFiles/rbd_internal.dir/cache/WriteAroundObjectDispatch.cc.o
[ 1752s] [ 49%] Building CXX object src/rgw/CMakeFiles/rgw_common.dir/rgw_formats.cc.o
[ 1757s] [ 50%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_deleter/TrashMoveRequest.cc.o
[ 1758s] [ 50%] Building CXX object src/mon/CMakeFiles/mon.dir/HealthMonitor.cc.o
[ 1770s] [ 51%] Building CXX object src/librbd/CMakeFiles/rbd_internal.dir/deep_copy/ImageCopyRequest.cc.o
[ 1784s] [ 51%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_deleter/TrashWatcher.cc.o
[ 1791s] [ 51%] Building CXX object src/rgw/CMakeFiles/rgw_common.dir/rgw_gc.cc.o
[ 1797s] [ 51%] Building CXX object src/librbd/CMakeFiles/rbd_internal.dir/deep_copy/MetadataCopyRequest.cc.o
[ 1799s] [ 51%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_map/LoadRequest.cc.o
[ 1807s] [ 51%] Building CXX object src/librbd/CMakeFiles/rbd_internal.dir/deep_copy/ObjectCopyRequest.cc.o
[ 1807s] [ 51%] Building CXX object src/mon/CMakeFiles/mon.dir/ConfigKeyService.cc.o
[ 1808s] [ 51%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_map/Policy.cc.o
[ 1813s] [ 51%] Building CXX object src/rgw/CMakeFiles/rgw_common.dir/rgw_http_client.cc.o
[ 1822s] [ 51%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_map/SimplePolicy.cc.o
[ 1830s] [ 51%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_map/StateTransition.cc.o
[ 1830s] [ 51%] Building CXX object src/librbd/CMakeFiles/rbd_internal.dir/deep_copy/SetHeadRequest.cc.o
[ 1832s] [ 51%] Building CXX object src/rgw/CMakeFiles/rgw_common.dir/rgw_json_enc.cc.o
[ 1834s] [ 51%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_map/UpdateRequest.cc.o
[ 1837s] [ 51%] Building CXX object src/mon/CMakeFiles/mon.dir/__/mds/MDSAuthCaps.cc.o
[ 1841s] [ 51%] Building CXX object src/librbd/CMakeFiles/rbd_internal.dir/deep_copy/SnapshotCopyRequest.cc.o
[ 1843s] [ 51%] Building CXX object src/tools/rbd_mirror/CMakeFiles/rbd_mirror_internal.dir/image_replayer/BootstrapRequest.cc.o
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_json_enc.cc: In member function 'virtual void rgw::keystone::AdminTokenRequestVer2::dump(ceph::Formatter*) const':
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_json_enc.cc:1531:64: error: no matching function for call to 'to_string(boost::string_ref)'
[ 1845s]          encode_json("username", to_string(conf.get_admin_user()), f);
[ 1845s]                                                                 ^
[ 1845s] In file included from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_iam_policy.h:32,
[ 1845s]                  from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_common.h:28,
[ 1845s]                  from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_json_enc.cc:4:
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_arn.h:70:20: note: candidate: 'std::__cxx11::string rgw::to_string(const rgw::ARN&)'
[ 1845s]  inline std::string to_string(const ARN& a) {
[ 1845s]                     ^~~~~~~~~
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_arn.h:70:20: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'const rgw::ARN&'
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_arn.h:106:20: note: candidate: 'std::__cxx11::string rgw::to_string(const rgw::ARNResource&)'
[ 1845s]  inline std::string to_string(const ARNResource& r) {
[ 1845s]                     ^~~~~~~~~
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_arn.h:106:20: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'const rgw::ARNResource&'
[ 1845s] In file included from /usr/include/c++/8/string:52,
[ 1845s]                  from /usr/include/c++/8/stdexcept:39,
[ 1845s]                  from /usr/include/c++/8/array:39,
[ 1845s]                  from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_common.h:20,
[ 1845s]                  from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_json_enc.cc:4:
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6453:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(int)'
[ 1845s]    to_string(int __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6453:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'int'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6458:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(unsigned int)'
[ 1845s]    to_string(unsigned __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6458:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'unsigned int'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6464:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(long int)'
[ 1845s]    to_string(long __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6464:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'long int'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6469:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(long unsigned int)'
[ 1845s]    to_string(unsigned long __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6469:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'long unsigned int'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6475:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(long long int)'
[ 1845s]    to_string(long long __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6475:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'long long int'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6481:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(long long unsigned int)'
[ 1845s]    to_string(unsigned long long __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6481:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'long long unsigned int'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6487:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(float)'
[ 1845s]    to_string(float __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6487:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'float'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6496:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(double)'
[ 1845s]    to_string(double __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6496:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'double'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6505:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(long double)'
[ 1845s]    to_string(long double __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6505:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'long double'
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_json_enc.cc:1534:66: error: no matching function for call to 'to_string(boost::string_ref)'
[ 1845s]        encode_json("tenantName", to_string(conf.get_admin_tenant()), f);
[ 1845s]                                                                   ^
[ 1845s] In file included from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_iam_policy.h:32,
[ 1845s]                  from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_common.h:28,
[ 1845s]                  from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_json_enc.cc:4:
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_arn.h:70:20: note: candidate: 'std::__cxx11::string rgw::to_string(const rgw::ARN&)'
[ 1845s]  inline std::string to_string(const ARN& a) {
[ 1845s]                     ^~~~~~~~~
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_arn.h:70:20: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'const rgw::ARN&'
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_arn.h:106:20: note: candidate: 'std::__cxx11::string rgw::to_string(const rgw::ARNResource&)'
[ 1845s]  inline std::string to_string(const ARNResource& r) {
[ 1845s]                     ^~~~~~~~~
[ 1845s] /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_arn.h:106:20: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'const rgw::ARNResource&'
[ 1845s] In file included from /usr/include/c++/8/string:52,
[ 1845s]                  from /usr/include/c++/8/stdexcept:39,
[ 1845s]                  from /usr/include/c++/8/array:39,
[ 1845s]                  from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_common.h:20,
[ 1845s]                  from /home/abuild/rpmbuild/BUILD/ceph-15.0.0-1046-g9a3fbdb4c0/src/rgw/rgw_json_enc.cc:4:
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6453:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(int)'
[ 1845s]    to_string(int __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6453:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'int'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6458:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(unsigned int)'
[ 1845s]    to_string(unsigned __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6458:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'unsigned int'
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6464:3: note: candidate: 'std::__cxx11::string std::__cxx11::to_string(long int)'
[ 1845s]    to_string(long __val)
[ 1845s]    ^~~~~~~~~
[ 1845s] /usr/include/c++/8/bits/basic_string.h:6464:3: note:   no known conversion for argument 1 from 'boost::string_ref' {aka 'boost::basic_string_ref<char, std::char_traits<char> >'} to 'long int'
...

Related issues

Copied to rgw - Backport #42838: nautilus: master/octopus FTBFS on s390x Resolved

History

#1 Updated by Casey Bodley 10 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 28013

I see a recent commit 2bd353233112ead32181b94a2af1b04e3fa9e1de that changed some of these calls:

-        encode_json("password", to_string(conf.get_admin_password()), f);
+        encode_json("password", ::to_string(conf.get_admin_password()), f);

The intent is to call this overload defined above in rgw_json_enc.cc:

/* This utility function shouldn't conflict with the overload of std::to_string    
 * provided by string_ref since Boost 1.54 as it's defined outside of the std      
 * namespace. I hope we'll remove it soon - just after merging the Matt's PR       
 * for bundled Boost. It would allow us to forget that CentOS 7 has Boost 1.53. */ 
static inline std::string to_string(const boost::string_ref& s)                    
{                                                                                  
  return std::string(s.data(), s.length());                                        
}

Applying that same change to all to_string() calls in rgw::keystone::AdminTokenRequestVer2::dump and

#2 Updated by Casey Bodley 10 months ago

  • Project changed from Ceph to rgw
  • Category deleted (build)

#3 Updated by Nathan Cutler 10 months ago

  • Assignee set to Casey Bodley

#4 Updated by Nathan Cutler 10 months ago

  • Status changed from Fix Under Review to Resolved

#5 Updated by Nathan Cutler 3 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to nautilus

#6 Updated by Nathan Cutler 3 months ago

#7 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF