Project

General

Profile

Bug #39587

[ceph-mgr]High cpu usage

Added by haitao chen 4 months ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/05/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

We are running ceph 13.2.5 on Centos Linux 7.5.1804.There have three monitors, three mgrs.
When do some operations on dashboard, the ceph-mgr's cpu become very high. Use 'pstack -T -p pid' and 'top -H' show that the msgr-worker-0, msgr-worker-1 and msgr-worker-2 thread take the cpu.
Use 'strace -p pid' to show that the msgr-worker-0~2 call epoll_wait very very very frequently.
Set debug_ms to 30/30 get some logs list below:

log2.png View (357 KB) haitao chen, 05/05/2019 08:22 AM

log3.png View (213 KB) haitao chen, 05/05/2019 09:36 AM


Related issues

Duplicates RADOS - Backport #38561: mimic: mgr deadlock Resolved

History

#1 Updated by Greg Farnum 3 months ago

  • Project changed from Ceph to mgr
  • Category deleted (msgr)

#2 Updated by haitao chen 2 months ago

It the same as http://tracker.ceph.com/issues/38561.
Because the dead lock, the mgr's queue of ceph-mgr can't release. So it will call epoll_wait very very frequently.

#3 Updated by haitao chen 2 months ago

Please help to close it.

#4 Updated by Sebastian Wagner 2 months ago

#5 Updated by Sebastian Wagner 2 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF