Project

General

Profile

Bug #39436

qa: upgrade task fails from mimic to master

Added by Patrick Donnelly 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
Pull request ID:

Description

Failure: 'wait_until_healthy' reached maximum tries (150) after waiting for 900 seconds
7 jobs: ['3856759', '3856805', '3856787', '3856859', '3856962', '3856913', '3857015']
suites intersection: ['1-client.yaml', '2-upgrade.yaml', 'clusters/1-mds-2-client-micro.yaml', 'conf/{client.yaml', 'mds.yaml', 'mon.yaml', 'osd.yaml}', 'overrides/{frag_enable.yaml', 'tasks/{0-mimic.yaml', 'whitelist_health.yaml', 'whitelist_wrongly_marked_down.yaml}']
suites union: ['1-client.yaml', '2-upgrade.yaml', '3-client-upgrade.yaml', '3-compat_client/mimic.yaml}}', '3-compat_client/no.yaml}}', '4-compat_client.yaml', '5-client-sanity.yaml}}', 'clusters/1-mds-2-client-micro.yaml', 'conf/{client.yaml', 'fs/upgrade/featureful_client/old_client/{bluestore-bitmap.yaml', 'fs/upgrade/featureful_client/upgraded_client/{bluestore-bitmap.yaml', 'mds.yaml', 'mon.yaml', 'multimds/no.yaml', 'multimds/yes.yaml', 'osd.yaml}', 'overrides/{frag_enable.yaml', 'tasks/{0-mimic.yaml', 'whitelist_health.yaml', 'whitelist_wrongly_marked_down.yaml}']

For example: /ceph/teuthology-archive/pdonnell-2019-04-17_06:02:40-fs-wip-pdonnell-testing-20190417.032809-distro-basic-smithi/3856759/teuthology.log

Looks like ceph command can't talk to the monitors after restarting the daemons. Probably a messenger v2 issue.

Should look at how we're doing mimic upgrades in other suites to fix.


Related issues

Related to fs - Bug #40374: nautilus: qa: disable "HEALTH_WARN Legacy BlueStore stats reporting..." Resolved

History

#1 Updated by Patrick Donnelly 4 months ago

  • Status changed from New to Need Review
  • Pull request ID set to 27731

#2 Updated by Patrick Donnelly 3 months ago

  • Status changed from Need Review to Resolved

#3 Updated by Patrick Donnelly 2 months ago

  • Related to Bug #40374: nautilus: qa: disable "HEALTH_WARN Legacy BlueStore stats reporting..." added

Also available in: Atom PDF