Project

General

Profile

Bug #39395

ceph: ceph fs auth fails

Added by Radosław Piliszek 4 months ago. Updated 10 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
Yes
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDSMonitor
Labels (FS):
Pull request ID:

Description

Since 12.2.12 documentation-backed example invocation of ceph fs authorize fails all the time:

# ceph fs authorize cephfs client.cephfs / rw
Error EINVAL: unknown cap type '/'

I attach verbose output.

verbose.txt View (16.4 KB) Radosław Piliszek, 04/20/2019 05:33 PM

History

#1 Updated by Patrick Donnelly 4 months ago

  • Project changed from Ceph to fs
  • Subject changed from Since 12.2.12 ceph fs auth fails to ceph: ceph fs auth fails
  • Category deleted (ceph cli)
  • Start date deleted (04/20/2019)
  • Tags deleted (cephfs)

#2 Updated by Patrick Donnelly 3 months ago

  • Assignee set to Varsha Rao
  • Target version set to v15.0.0
  • Component(FS) MDSMonitor added

src/mon/AuthMonitor.cc src/mds/MDSMonitor.cc

#3 Updated by Varsha Rao 3 months ago

  • Status changed from New to Verified

This issue is fixed in the latest version. On luminous, I get the same error.

#4 Updated by Varsha Rao about 2 months ago

  • Status changed from Verified to In Progress
  • Target version changed from v15.0.0 to v12.2.13
  • Source set to Development

#5 Updated by Varsha Rao about 2 months ago

  • Status changed from In Progress to Need Review
  • Pull request ID set to 28666

#7 Updated by Varsha Rao 10 days ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF