Project

General

Profile

Bug #39353

Error message displayed when mon_osd_max_split_count would be exceeded is not as user-friendly as it could be

Added by Nathan Cutler 4 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/17/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

Under certain circumstances, an attempt to increase the PG count of a pool can fail like this:

$ ceph osd pool set foopool pg_num 512
Error E2BIG: specified pg_num 512 is too large (creating 504 new PGs on ~8 OSDs exceeds per-OSD max of 32)

This error can be addressed in two ways: either by increasing mon_osd_max_split_count or by simply increasing the pg_num in smaller increments. However, the error message does not mention either possibility.

This issue affects only mimic and luminous, because the error message (and indeed the mon_osd_max_split_count option itself) was removed in Nautilus.

The issue was partially addressed by https://github.com/ceph/ceph/commit/d2c0fe9b531 in Mimic.


Related issues

Copied to RADOS - Backport #39563: luminous: Error message displayed when mon_osd_max_split_count would be exceeded is not as user-friendly as it could be Resolved

History

#1 Updated by Nathan Cutler 4 months ago

  • Description updated (diff)

#2 Updated by Nathan Cutler 4 months ago

  • Status changed from New to Need Review
  • Pull request ID set to 27647

#3 Updated by Nathan Cutler 4 months ago

  • Affected Versions v12.2.12 added

#4 Updated by Nathan Cutler 4 months ago

  • Subject changed from Error message displayed when mon_osd_max_split_count would be exceeded is not user-friendly to Error message displayed when mon_osd_max_split_count would be exceeded is not as user-friendly as it could be

#5 Updated by Nathan Cutler 4 months ago

  • Project changed from Ceph to RADOS

#7 Updated by Nathan Cutler 4 months ago

  • Status changed from Need Review to Pending Backport

#8 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #39563: luminous: Error message displayed when mon_osd_max_split_count would be exceeded is not as user-friendly as it could be added

#9 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF