Project

General

Profile

Bug #39282

EIO from process_copy_chunk_manifest

Added by Sage Weil 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
04/12/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

Description

2019-04-12 16:21:19.773 7f2683cad700 10 osd.0 pg_epoch: 33 pg[3.f( v 33'344 (0'0,33'344] local-lis/les=19/20 n=21 ec=19/19 lis/c 19/19 les/c/f 20/20/0 19/19/19) [0,1] r=0 lpr=19 crt=33'344 lcod 33'343 mlcod 33'343 active+clean] process_copy_chunk_manifest 3:f8e8897a:::smithi19213410-238:head tid 83 (0) Success
2019-04-12 16:21:19.773 7f2683cad700 20 osd.0 pg_epoch: 33 pg[3.f( v 33'344 (0'0,33'344] local-lis/les=19/20 n=21 ec=19/19 lis/c 19/19 les/c/f 20/20/0 19/19/19) [0,1] r=0 lpr=19 crt=33'344 lcod 33'343 mlcod 33'343 active+clean] process_copy_chunk_manifest complete r = (5) Input/output error

/a/nojha-2019-04-12_14:38:37-rados-wip-27381-distro-basic-smithi/3838364

looks like maybe

  if (!chunk_data.outdata.length()) {
    r = -EIO;
    obj_cop->failed = true;
    goto out;
  }

result is

2019-04-12T16:21:20.494 INFO:tasks.rados.rados.0.smithi192.stdout:3749: read oid 116 snap -1
2019-04-12T16:21:20.494 INFO:tasks.rados.rados.0.smithi192.stdout:3749:  expect (ObjNum 115 snap 0 seq_num 115)
2019-04-12T16:21:20.494 INFO:tasks.rados.rados.0.smithi192.stderr:3746: Error: oid 238 read returned error code -5
2019-04-12T16:21:20.495 INFO:tasks.rados.rados.0.smithi192.stderr:/build/ceph-15.0.0-7-g75ed3b0/src/test/osd/RadosModel.h: In function 'virtual void ReadOp::_finish(TestOp::CallbackInfo*)' thread 7fc8baffd700 time 2019-04-12 16:21:20.506432
2019-04-12T16:21:20.495 INFO:tasks.rados.rados.0.smithi192.stderr:/build/ceph-15.0.0-7-g75ed3b0/src/test/osd/RadosModel.h: 1391: abort()
2019-04-12T16:21:20.495 INFO:tasks.rados.rados.0.smithi192.stderr: ceph version 15.0.0-7-g75ed3b0 (75ed3b09cadb38bb3f2856ca93e6eb6d075bfdf7) octopus (dev)

History

#1 Updated by Myoungwon Oh 7 months ago

  • Assignee set to Myoungwon Oh

#3 Updated by Sage Weil 5 months ago

  • Status changed from Verified to Resolved

Also available in: Atom PDF