Project

General

Profile

Bug #39263

rados/upgrade/nautilus-x-singleton: mon.c@1(electing).elector(11) Shutting down because I lack required monitor features

Added by Neha Ojha about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

Description

2019-04-11T02:35:51.042 INFO:tasks.ceph.mon.c.smithi157.stderr:2019-04-11 02:35:51.045 7f67fb64e700 -1 mon.c@1(electing).elector(11) Shutting down because I lack required monitor features: { compat={},rocompat={},incompat={} } mon_feature_t([none])
2019-04-11T02:37:45.047 DEBUG:teuthology.orchestra.run:got remote process result: 124

Followed by this

202019-04-11T02:38:14.415 INFO:teuthology.orchestra.run.smithi082:> sudo ceph --cluster ceph tell 'mon.*' injectargs -- --no-mon-health-to-clog19-04-11T02:38:14.754 INFO:teuthology.orchestra.run.smithi082.stderr:mon.a: injectargs:mon_health_to_clog = 'false'
2019-04-11T02:53:14.553 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 02:53:14.571 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e78016350 legacy=0x7f1e780187f0 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T03:08:14.576 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 03:08:14.573 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e780239d0 legacy=0x7f1e78025e20 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T03:23:14.576 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 03:23:14.574 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e7801fb80 legacy=0x7f1e78022040 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T03:38:14.577 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 03:38:14.575 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e780269d0 legacy=0x7f1e78026dd0 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T03:53:14.578 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 03:53:14.577 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e78021c70 legacy=0x7f1e78024080 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T04:08:14.580 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 04:08:14.578 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e780269e0 legacy=0x7f1e78026de0 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T04:23:14.581 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 04:23:14.579 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e7801e450 legacy=0x7f1e7801e850 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T04:38:14.582 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 04:38:14.579 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e78016350 legacy=0x7f1e78018760 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T04:53:14.583 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 04:53:14.581 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e7801e9b0 legacy=0x7f1e78025980 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T05:08:14.584 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:08:14.582 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e78026ce0 legacy=0x7f1e78019370 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T05:23:14.590 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:23:14.583 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e78019c00 legacy=0x7f1e78018b50 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T05:38:14.585 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:14.583 7f1e99b62700  0 -- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e78019770 legacy=0x7f1e78021db0 unknown :-1 s=STATE_CLOSED l=1).tick see no progress in more than 10000000 us during connecting, fault.
2019-04-11T05:38:14.982 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:14.583 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e780235b0 0x7f1e780259c0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:15.585 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:15.583 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:16.585 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:16.583 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:17.586 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:17.584 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:18.586 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:18.584 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:19.586 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:19.584 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:20.586 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:20.584 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:21.586 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:21.584 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:22.586 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:22.584 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:23.587 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:23.584 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:24.586 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:24.585 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:25.586 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:25.585 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:26.587 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:26.584 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER
2019-04-11T05:38:27.589 INFO:teuthology.orchestra.run.smithi082.stderr:2019-04-11 05:38:27.585 7f1e99b62700  0 --1- 172.21.15.82:0/3998914394 >> v1:172.21.15.82:6800/9855 conn(0x7f1e64002cd0 0x7f1e640051f0 :-1 s=CONNECTING_SEND_CONNECT_MSG pgs=0 cs=0 l=1).handle_connect_reply_2 connect got BADAUTHORIZER

/a/kchai-2019-04-11_01:06:08-rados-wip-kefu-testing-2019-04-09-1348-distro-basic-smithi/3832468/


Related issues

Copied to RADOS - Backport #39419: nautilus: rados/upgrade/nautilus-x-singleton: mon.c@1(electing).elector(11) Shutting down because I lack required monitor features Resolved

History

#1 Updated by Neha Ojha about 1 year ago

  • Status changed from New to 12
  • Priority changed from Normal to High

/a/nojha-2019-04-11_19:53:24-rados-wip-parial-recovery-2019-04-11-distro-basic-smithi/3834700/

#2 Updated by Sage Weil about 1 year ago

  • Status changed from 12 to Fix Under Review

#3 Updated by Neha Ojha about 1 year ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to nautilus

#4 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #39419: nautilus: rados/upgrade/nautilus-x-singleton: mon.c@1(electing).elector(11) Shutting down because I lack required monitor features added

#5 Updated by Nathan Cutler 12 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF