Project

General

Profile

Bug #39154

Don't mark removed osds in when running "ceph osd in any|all|*"

Added by Brad Hubbard 12 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Administration/Usability
Target version:
-
% Done:

0%

Source:
Support
Tags:
Backport:
nautilus, mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

Description

To reproduce.

ceph osd out 2
init-ceph stop osd.2
ceph osd purge 2 --yes-i-really-mean-it
ceph -s 2>&1|grep osd:                                                                                                                                                                          
    osd: 5 osds: 5 up (since 63s), 5 in (since 90s)
ceph osd in any
marked in osd.2.
ceph -s 2>&1|grep osd:
    osd: 6 osds: 5 up (since 2m), 6 in (since 78s)

Related issues

Copied to RADOS - Backport #39420: luminous: Don't mark removed osds in when running "ceph osd in any|all|*" Resolved
Copied to RADOS - Backport #39421: nautilus: Don't mark removed osds in when running "ceph osd in any|all|*" Resolved
Copied to RADOS - Backport #39422: mimic: Don't mark removed osds in when running "ceph osd in any|all|*" Resolved

History

#1 Updated by Brad Hubbard 12 months ago

  • Description updated (diff)

#2 Updated by Brad Hubbard 12 months ago

  • Pull request ID set to 27663

#3 Updated by Brad Hubbard 12 months ago

  • Status changed from 12 to Fix Under Review

#4 Updated by Brad Hubbard 12 months ago

  • Status changed from Fix Under Review to In Progress

#5 Updated by Brad Hubbard 12 months ago

  • Backport set to nautilus, mimic, luminous

#6 Updated by Sage Weil 12 months ago

  • Status changed from In Progress to Pending Backport

#7 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #39420: luminous: Don't mark removed osds in when running "ceph osd in any|all|*" added

#8 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #39421: nautilus: Don't mark removed osds in when running "ceph osd in any|all|*" added

#9 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #39422: mimic: Don't mark removed osds in when running "ceph osd in any|all|*" added

#10 Updated by Nathan Cutler 8 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF